summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 21:03:38 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:25 +0200
commitfdc276e65566beb3c91b69585061e4d11bd8b9d8 (patch)
tree8e4f4b7c51ab252ad87d449cbafec98e936b7bd8 /games-arcade
parentgames-arcade/thinktanks-demo: Drop old (diff)
downloadgentoo-fdc276e65566beb3c91b69585061e4d11bd8b9d8.tar.gz
gentoo-fdc276e65566beb3c91b69585061e4d11bd8b9d8.tar.bz2
gentoo-fdc276e65566beb3c91b69585061e4d11bd8b9d8.zip
games-arcade/triplexinvaders: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch16
-rw-r--r--games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild44
2 files changed, 52 insertions, 8 deletions
diff --git a/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
index 56f9c1a1596a..85c88afcfe8a 100644
--- a/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
+++ b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
@@ -1,5 +1,5 @@
---- sound.py.old 2007-04-14 21:52:02.000000000 +0200
-+++ sound.py 2007-04-14 21:52:27.000000000 +0200
+--- a/sound.py.old 2007-04-14 21:52:02.000000000 +0200
++++ b/sound.py 2007-04-14 21:52:27.000000000 +0200
@@ -16,7 +16,7 @@
@@ -18,8 +18,8 @@
sound.set_volume(volume)
LoadedSounds[name] = sound
return LoadedSounds[name]
---- util.py.old 2007-04-14 21:56:30.000000000 +0200
-+++ util.py 2007-04-14 21:56:48.000000000 +0200
+--- a/util.py.old 2007-04-14 21:56:30.000000000 +0200
++++ b/util.py 2007-04-14 21:56:48.000000000 +0200
@@ -30,7 +30,7 @@
LoadedTextures = weakref.WeakValueDictionary()
@@ -38,8 +38,8 @@
LoadedModels[name] = model
return LoadedModels[name]
---- hiscore.py.old 2007-04-14 22:04:04.000000000 +0200
-+++ hiscore.py 2007-04-14 22:04:25.000000000 +0200
+--- a/hiscore.py.old 2007-04-14 22:04:04.000000000 +0200
++++ b/hiscore.py 2007-04-14 22:04:25.000000000 +0200
@@ -5,7 +5,7 @@
# copy the highscores to the user's homedir
highscorefile = os.path.join(configdir, 'hiscores')
@@ -49,8 +49,8 @@
shutil.copy(oldpath, highscorefile)
def write(score, name):
---- options.py.old 2007-04-14 22:05:23.000000000 +0200
-+++ options.py 2007-04-14 22:05:42.000000000 +0200
+--- a/options.py.old 2007-04-14 22:05:23.000000000 +0200
++++ b/options.py 2007-04-14 22:05:42.000000000 +0200
@@ -5,7 +5,7 @@
# copy the options to the user's homedir
optionfile = os.path.join(configdir, 'options.conf')
diff --git a/games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild b/games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild
new file mode 100644
index 000000000000..09ac13da91d5
--- /dev/null
+++ b/games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="An Alien Invaders style game with 3d graphics"
+HOMEPAGE="http://triplexinvaders.infogami.com"
+SRC_URI="http://acm.jhu.edu/~arthur/invaders/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+"
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ sound.py \
+ util.py \
+ hiscore.py \
+ options.py || die "sed failed"
+}
+
+src_install() {
+ local libdir=/usr/$(get_libdir)
+
+ insinto "${libdir}/${PN}"
+ doins -r *.py
+ insinto "/usr/share/${PN}"
+ doins -r models sound options.conf hiscores
+ make_wrapper ${PN} "python2 ./invaders.py" "${libdir}/${PN}"
+ einstalldocs
+ make_desktop_entry ${PN}
+}