summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 13:20:35 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-08 13:24:27 -0500
commit9168c3eb358259c3c3e80fedf1019607d179ada6 (patch)
tree7b624eaf7ec9abbcf739e6a282f48b825a6e94bf /games-board/ascal/ascal-0.1.1-r1.ebuild
parentgames-board/atakks: remove deprecated games eclass (diff)
downloadgentoo-9168c3eb358259c3c3e80fedf1019607d179ada6.tar.gz
gentoo-9168c3eb358259c3c3e80fedf1019607d179ada6.tar.bz2
gentoo-9168c3eb358259c3c3e80fedf1019607d179ada6.zip
games-board/ascal: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/ascal/ascal-0.1.1-r1.ebuild')
-rw-r--r--games-board/ascal/ascal-0.1.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-board/ascal/ascal-0.1.1-r1.ebuild b/games-board/ascal/ascal-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..f00b82c296da
--- /dev/null
+++ b/games-board/ascal/ascal-0.1.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A game similar to Draughts but with some really cool enhancements"
+HOMEPAGE="http://ascal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ascal/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/libglademm
+ dev-cpp/libgnomecanvasmm
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf
+}