summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-09-28 16:44:20 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2015-09-28 16:44:35 -0400
commitb39e2410025905723a133f99677a65bd90a67129 (patch)
tree2c2e8804b241ba6734dede05d0bc892c274eb71e /games-board/domination/domination-1.1.1.6.ebuild
parentversion bump (diff)
downloadgentoo-b39e2410025905723a133f99677a65bd90a67129.tar.gz
gentoo-b39e2410025905723a133f99677a65bd90a67129.tar.bz2
gentoo-b39e2410025905723a133f99677a65bd90a67129.zip
version bump (bug #561712)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-board/domination/domination-1.1.1.6.ebuild')
-rw-r--r--games-board/domination/domination-1.1.1.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-board/domination/domination-1.1.1.6.ebuild b/games-board/domination/domination-1.1.1.6.ebuild
new file mode 100644
index 000000000000..3c370a7c1aef
--- /dev/null
+++ b/games-board/domination/domination-1.1.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+EANT_BUILD_TARGET="game"
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ newgamesbin "${S}"/FlashGUI.sh ${PN}
+ sed -i \
+ -e "s|cd.*|cd \"${GAMES_DATADIR}\"/${PN}|" \
+ "${D}${GAMES_BINDIR}"/${PN} \
+ || die
+ chmod +x "${D}${GAMES_BINDIR}"/${PN} || die
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r "${S}"/*
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+
+ prepgamesdirs
+}