summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/freedoko/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/freedoko/files')
-rw-r--r--games-board/freedoko/files/Fix_Cardset_Make.patch12
-rw-r--r--games-board/freedoko/files/freedoko-0.7.13-gentoo.patch45
-rw-r--r--games-board/freedoko/files/nodoc.patch10
-rw-r--r--games-board/freedoko/files/nonet.patch11
-rw-r--r--games-board/freedoko/files/portage-cxx.patch12
5 files changed, 90 insertions, 0 deletions
diff --git a/games-board/freedoko/files/Fix_Cardset_Make.patch b/games-board/freedoko/files/Fix_Cardset_Make.patch
new file mode 100644
index 000000000000..32bdc32885aa
--- /dev/null
+++ b/games-board/freedoko/files/Fix_Cardset_Make.patch
@@ -0,0 +1,12 @@
+--- data/cardsets/Makefile.orig
++++ data/cardsets/Makefile
+@@ -12,8 +12,7 @@
+ @# In order to add all cardsets to the release
+ @# uncomment the following line, add a trailing backslash
+ @# and remove the line after
+- @#for d in Altenburg xskat kdecarddecks pysol; do
+- for d in Altenburg; do \
++ for d in Altenburg xskat kdecarddecks pysol; do \
+ cp -r $$d $(DEPTH)/release/FreeDoko_$(VERSION)/cardsets/; \
+ done
+ endif
diff --git a/games-board/freedoko/files/freedoko-0.7.13-gentoo.patch b/games-board/freedoko/files/freedoko-0.7.13-gentoo.patch
new file mode 100644
index 000000000000..91bd228186b6
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.13-gentoo.patch
@@ -0,0 +1,45 @@
+diff -ru FreeDoko_0.7.13.orig/src/Makefile FreeDoko_0.7.13/src/Makefile
+--- FreeDoko_0.7.13.orig/src/Makefile 2014-12-29 15:41:58.000000000 -0500
++++ FreeDoko_0.7.13/src/Makefile 2015-01-27 13:23:11.498892598 -0500
+@@ -242,15 +242,7 @@
+ # compile FreeDoko
+ $(PROGRAM) : show_settings objects $(DIRECTORIES)
+ @echo 'compiling $(PROGRAM)...'
+-# Gentoo users do want to see the real compile line.
+-# So remove the next five lines (the echo lines)
+-# and remove the '@' in the line after.
+- @echo '$(CXX) $(CXXFLAGS)'
+- @echo ' $$(OBJECTS)'
+- @echo ' $(INCLUDE_ALL)'
+- @echo ' $(LIBS_ALL)'
+- @echo ' -o $@'
+- @$(CXX) $(CXXFLAGS) \
++ $(CXX) $(CXXFLAGS) \
+ $(OBJECTS_ALL:%.o=$(FREEDOKO_WORKING_DIRECTORY)/%.o) \
+ $(INCLUDE_ALL) \
+ $(LIBS_ALL) \
+diff -ru FreeDoko_0.7.13.orig/src/Makefile.os FreeDoko_0.7.13/src/Makefile.os
+--- FreeDoko_0.7.13.orig/src/Makefile.os 2014-12-29 15:41:58.000000000 -0500
++++ FreeDoko_0.7.13/src/Makefile.os 2015-01-27 13:23:22.185483548 -0500
+@@ -1,6 +1,5 @@
+ include $(DEPTH)/../Makefile.os
+
+-include $(DEPTH)/Makefile.local
+ include $(DEPTH)/Makefile.modules
+
+ ifeq ($(OPERATING_SYSTEM), Linux)
+diff -ru FreeDoko_0.7.13.orig/src/Makefile.rules FreeDoko_0.7.13/src/Makefile.rules
+--- FreeDoko_0.7.13.orig/src/Makefile.rules 2014-12-29 15:41:58.000000000 -0500
++++ FreeDoko_0.7.13/src/Makefile.rules 2015-01-27 13:23:44.780618643 -0500
+@@ -80,10 +80,7 @@
+ $(DEPTH)/Makefile.modules \
+ $(DEPTH)/Makefile.local \
+ $(DEPTH)/Makefile.os
+-# Gentoo users do want to see the real compile line.
+-# So remove the next line and remove the '@' in the line after.
+- @echo $(CXX) -c $(SUBDIR)/$<
+- @$(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
+
+
+ -include $(OBJECTS:%.o=$(TARGET_DIR_LOCAL)%.d)
diff --git a/games-board/freedoko/files/nodoc.patch b/games-board/freedoko/files/nodoc.patch
new file mode 100644
index 000000000000..b3741a3aaf22
--- /dev/null
+++ b/games-board/freedoko/files/nodoc.patch
@@ -0,0 +1,10 @@
+--- Makefile.orig
++++ Makefile
+@@ -139,7 +139,6 @@
+ $(MAKE) Version
+ cp AUTHORS COPYING ChangeLog README LIESMICH Version release/FreeDoko_$(VERSION)/
+ $(MAKE) -C data release
+- $(MAKE) -C doc release
+ $(RM) -r `find release/FreeDoko_$(VERSION)/ -name ".svn"`
+
+ .PHONY: release_linux_binary
diff --git a/games-board/freedoko/files/nonet.patch b/games-board/freedoko/files/nonet.patch
new file mode 100644
index 000000000000..1902dd5668bd
--- /dev/null
+++ b/games-board/freedoko/files/nonet.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.modules.orig
++++ src/Makefile.modules
+@@ -11,7 +11,7 @@
+ # The network code
+ # It is not necessary for single players
+ # The network does use the 'GNet' library (http://www.gnetlibrary.org/)
+-USE_NETWORK ?= true
++USE_NETWORK ?= false
+
+ # whether to use thread support (experimental, use at your own risk)
+ #USE_THREADS ?= true
diff --git a/games-board/freedoko/files/portage-cxx.patch b/games-board/freedoko/files/portage-cxx.patch
new file mode 100644
index 000000000000..894b48010e39
--- /dev/null
+++ b/games-board/freedoko/files/portage-cxx.patch
@@ -0,0 +1,12 @@
+--- src/Makefile.rules.orig
++++ src/Makefile.rules
+@@ -5,8 +5,7 @@
+ $(DEPTH)/Makefile.os
+ # Gentoo users do want to see the real compile line.
+ # So remove the next line and remove the '@' in the line after.
+- @echo $(CXX) -c $<
+- @$(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
+
+ -include $(OBJECTS:.o=.d)
+