summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/gtkboard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/gtkboard')
-rw-r--r--games-board/gtkboard/Manifest1
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch24
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch22
-rw-r--r--games-board/gtkboard/gtkboard-0.11_pre0.ebuild50
-rw-r--r--games-board/gtkboard/metadata.xml8
5 files changed, 105 insertions, 0 deletions
diff --git a/games-board/gtkboard/Manifest b/games-board/gtkboard/Manifest
new file mode 100644
index 000000000000..10e38f656cdc
--- /dev/null
+++ b/games-board/gtkboard/Manifest
@@ -0,0 +1 @@
+DIST gtkboard-0.11pre0.tar.gz 459581 SHA256 e67ffbec822ce989c9b480b9ef0429bcc75fb2dcdf349940d7d5f9f85da902c5 SHA512 09d4a1d5203ef0e21d21b5b6cb351add71d0a415ad83808b6e281dcf3f869221e99ae683846462d465eaac54f5eb292e1d8447ea7cdfb07602a8add49e2db283 WHIRLPOOL 4dbf967c31b8a1f6fb044f3a22851e2b843b32c908609d1120f9879814163a83cec6db7152c68beebb606db817293b86750b908d7c4d2f8b002dc6c48cbed56c
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
new file mode 100644
index 000000000000..2e6a4c6f83ce
--- /dev/null
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
@@ -0,0 +1,24 @@
+gcc-4.1 patch from debian.
+
+--- src/board.c
++++ src/board.c
+@@ -74,7 +74,7 @@
+ //! default background
+ char board_default_colors [9] = {215, 215, 215, 215, 215, 215, 0, 0, 0};
+
+-static int cell_size, num_pieces;
++int cell_size, num_pieces;
+
+ extern void ui_make_human_move (byte *move, int *rmove);
+
+--- src/menu.c
++++ src/menu.c
+@@ -829,7 +829,7 @@
+
+ {
+ int i;
+- GtkItemFactoryEntry help_items [3];
++ GtkItemFactoryEntry help_items [4];
+ help_items[0].path = g_strdup_printf ("/Help/%s", opt_game->name);
+ help_items[0].accelerator = NULL;
+ help_items[0].callback = NULL;
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
new file mode 100644
index 000000000000..300e528c9ef7
--- /dev/null
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
@@ -0,0 +1,22 @@
+--- src/menu.c.old 2010-05-24 12:35:15.000000000 +0200
++++ src/menu.c 2010-05-24 12:35:48.000000000 +0200
+@@ -176,7 +176,7 @@
+ {
+ #if GTK_MAJOR_VERSION == 2
+ // FIXME: can't get existing bgcolor
+- const int size = 20;
++#define size 20
+ static char pixbufs [7][size*(size+1)];
+ char **pixmap_data;
+ static GdkPixmap *pixmaps[7];
+--- src/wordtris.c.old 2010-05-24 12:36:50.000000000 +0200
++++ src/wordtris.c 2010-05-24 12:38:30.000000000 +0200
+@@ -122,7 +122,7 @@
+
+ // TODO: change this so that we only need to specify pixmaps for individual squares
+
+-static const int lava_xpm_header_size = 253+1;
++#define lava_xpm_header_size 253+1
+ static char * lava_xpm_header[] =
+ {
+ "144 504 253 2",
diff --git a/games-board/gtkboard/gtkboard-0.11_pre0.ebuild b/games-board/gtkboard/gtkboard-0.11_pre0.ebuild
new file mode 100644
index 000000000000..b07d0efb1b58
--- /dev/null
+++ b/games-board/gtkboard/gtkboard-0.11_pre0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P=${P/_}
+DESCRIPTION="Board games system"
+HOMEPAGE="http://gtkboard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="gnome"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/libsdl:0[sound]
+ media-libs/sdl-mixer[vorbis]
+ gnome? ( gnome-base/libgnomeui )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
+ sed -i -e "/^LIBS/s:@LIBS@:@LIBS@ -lgmodule-2.0 -lm:" \
+ src/Makefile.in
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --datadir="${GAMES_DATADIR}"/${PN} \
+ --enable-gtk2 \
+ --enable-sdl \
+ $(use_enable gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doicon pixmaps/${PN}.png
+ make_desktop_entry ${PN} Gtkboard
+ dodoc AUTHORS ChangeLog TODO
+ dohtml doc/index.html
+ prepgamesdirs
+}
diff --git a/games-board/gtkboard/metadata.xml b/games-board/gtkboard/metadata.xml
new file mode 100644
index 000000000000..3ed92536ef9b
--- /dev/null
+++ b/games-board/gtkboard/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">gtkboard</remote-id>
+ </upstream>
+</pkgmetadata>