summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/pouetchess
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/pouetchess')
-rw-r--r--games-board/pouetchess/Manifest1
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch12
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-nvidia_glext.patch12
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch29
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch57
-rw-r--r--games-board/pouetchess/metadata.xml8
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0-r1.ebuild64
7 files changed, 183 insertions, 0 deletions
diff --git a/games-board/pouetchess/Manifest b/games-board/pouetchess/Manifest
new file mode 100644
index 000000000000..50b4d832e6ac
--- /dev/null
+++ b/games-board/pouetchess/Manifest
@@ -0,0 +1 @@
+DIST pouetchess_src_0.2.0.tar.gz 1055338 SHA256 fe966ff1b0aa2dd6d0ca2b62692f5b788e3a286050a6a374e58ca0612f68b2ef SHA512 20d9b2edc3e3998716eddd38b82226f5c1298b9bf5cabc56a545bee602ce3e7a9106f130265f2b0d31ee56d728da2cc54a79623faa6841732cde0d7d94c33acf WHIRLPOOL d18b69de08fc4b45adbe924e2f859cd8bb9e84f23c02a60c214f3f9823d02152c7c5d073ed85574267558968ce03721485c195bdbe41ccb890f5e3efa438cd5c
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch b/games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch
new file mode 100644
index 000000000000..0a60c2117da8
--- /dev/null
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch
@@ -0,0 +1,12 @@
+--- src/sxmlgui/XMLUtils.h.orig 2008-06-14 14:50:16.000000000 +0000
++++ src/sxmlgui/XMLUtils.h 2008-06-14 14:50:33.000000000 +0000
+@@ -38,6 +38,8 @@
+ #include <stdio.h>
+ #include <assert.h>
+ #include <fstream>
++#include <cstring>
++
+
+ // Help out windows:
+ #if defined( _DEBUG ) && !defined( DEBUG )
+
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-nvidia_glext.patch b/games-board/pouetchess/files/pouetchess-0.2.0-nvidia_glext.patch
new file mode 100644
index 000000000000..952f6dc85add
--- /dev/null
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-nvidia_glext.patch
@@ -0,0 +1,12 @@
+--- src/sxmlgui/GenUtils.h 2006-05-27 03:22:57.000000000 +0200
++++ src/sxmlgui/GenUtils.h.new 2006-06-12 20:35:32.000000000 +0200
+@@ -5,6 +5,9 @@
+ #include <iostream>
+ #include <fstream>
+ #include <vector>
++#ifndef GL_GLEXT_PROTOTYPES
++#define GL_GLEXT_PROTOTYPES 1
++#endif
+ #include <SDL/SDL_opengl.h>
+
+ #define deleteObject(A){ if(A){ delete A; A = NULL; } }
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch b/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch
new file mode 100644
index 000000000000..cea3a5a451af
--- /dev/null
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch
@@ -0,0 +1,29 @@
+--- SConstruct
++++ SConstruct
+@@ -22,14 +22,24 @@
+
+
+
+-import os,glob
++import os,glob,SCons.Util
+
+
++# http://dev.gentoo.org/~vapier/scons-blows.txt
+
+ # create build environment
+
++env = Environment()
++env.SConsignFile()
+ env = Environment(tools = ['default', 'pouetChess'], toolpath = ['.'])
+-env.AppendUnique(CXXFLAGS = ['-Wall'])
++env['CC'] = os.environ['CC']
++env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] = SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] = SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] = SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ # gather a list of source files
+ SOURCES = glob.glob('src/*.cpp')
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch b/games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch
new file mode 100644
index 000000000000..58780e1b275e
--- /dev/null
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch
@@ -0,0 +1,57 @@
+--- src/faile/search.c
++++ src/faile/search.c
+@@ -805,6 +805,7 @@
+ for (j = 0; j < indent; j++) {
+ fputc (' ', output);
+ }
++ void print_move (move_s moves[], int m, FILE *stream);
+ print_move (&moves[0], i, output);
+ fprintf (output, "\n");
+
+--- src/faile/utils.c
++++ src/faile/utils.c
+@@ -125,7 +125,7 @@
+ rank (target) < 1 || rank (target) > 8 ||
+ file (target) < 1 || file (target) > 8)
+ {
+- sprintf (str, "*** FAILE INTERNAL ERROR ***");
++ sprintf (str, "xxxx");
+ return;
+ }
+
+--- src/main.cpp
++++ src/main.cpp
+@@ -184,6 +184,9 @@
+ // first scene is SCENE_INIT.
+ pGlobalInfos->SetCurrentScene(GAME_SCENE_INIT);
+
++ /* @FB 02/08/06 */
++ pGlobalInfos->ReleaseKeys();
++
+ // main game loop
+ while( pGlobalInfos->IsGameRunning() )
+ {
+--- src/scene_main_game.cpp
++++ src/scene_main_game.cpp
+@@ -245,7 +245,7 @@
+
+ if (pGlobalInfos->OnLeftMouseButtonDown())
+ {
+- if (chessboard->clickOnChessBoard(mouseX,mouseY,&sqX,&sqY));
++ if (chessboard->clickOnChessBoard(mouseX,mouseY,&sqX,&sqY))
+ {
+ // if a piece was already selected, this means the player want to move this piece
+ if (SquareXSelected>-1 && SquareZSelected>-1)
+--- src/graphic_chessboard.cpp.old 2011-03-23 08:08:40.000000000 +0100
++++ src/graphic_chessboard.cpp 2011-03-23 08:33:04.000000000 +0100
+@@ -122,8 +122,8 @@
+
+ for(int i=0;i<6;i++)
+ {
+- char texture_filename[50];
+- sprintf(texture_filename,PC_DATA_TEXTURE_SKYBOX,i),
++ char texture_filename[256];
++ snprintf(texture_filename,sizeof(texture_filename),PC_DATA_TEXTURE_SKYBOX,i),
+ texture_skybox[i] = new CBasicTexture;
+ if (false==texture_skybox[i]->load(texture_filename,false))
+ {
diff --git a/games-board/pouetchess/metadata.xml b/games-board/pouetchess/metadata.xml
new file mode 100644
index 000000000000..2deafbec1ca3
--- /dev/null
+++ b/games-board/pouetchess/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">pouetchess</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..65e027e58cba
--- /dev/null
+++ b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils scons-utils games
+
+MY_PN=${PN/c/C}
+DESCRIPTION="3D and open source chess game"
+HOMEPAGE="http://pouetchess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_src_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug"
+
+DEPEND="media-libs/libsdl:0[opengl,video]
+ media-libs/sdl-image[jpeg,png]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN}_src_${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-sconstruct-sandbox.patch" \
+ "${FILESDIR}/${P}-nvidia_glext.patch" \
+ "${FILESDIR}/${P}-segfaults.patch" \
+ "${FILESDIR}/${P}-gcc43.patch"
+ # Fix for LibSDL >= 1.2.10 detection
+ sed -i \
+ -e "s:sdlver.split('.') >= \['1','2','8'\]:sdlver.split('.') >= [1,2,8]:" \
+ pouetChess.py || die
+}
+
+src_configure() {
+ # turn off the hackish optimization setting code (bug #230127)
+ scons configure \
+ strip=false \
+ optimize=false \
+ prefix="${GAMES_PREFIX}" \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use debug && echo debug=1) || die
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ dogamesbin bin/${MY_PN}
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+
+ dodoc ChangeLog README
+
+ doicon data/icons/${MY_PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN} "KDE;Qt;Game;BoardGame"
+
+ prepgamesdirs
+}