summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-12 10:11:49 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-12 10:12:12 +0100
commitefe212ccd4e79cd70c9d343912913038445d84ee (patch)
tree5315448dcf817322b0bdf80a36cc6408dfefc3d8 /games-board/sirius/sirius-0.8.0-r1.ebuild
parentsys-apps/mlocate: Removed old. (diff)
downloadgentoo-efe212ccd4e79cd70c9d343912913038445d84ee.tar.gz
gentoo-efe212ccd4e79cd70c9d343912913038445d84ee.tar.bz2
gentoo-efe212ccd4e79cd70c9d343912913038445d84ee.zip
games-board/sirius: Fix underlinking
Gentoo-bug: 592414 * Turn sed's into PATCHES * Fix configure.ac * Include a check for sqrt() in libm * Simplify ebuild Package-Manager: portage-2.3.3
Diffstat (limited to 'games-board/sirius/sirius-0.8.0-r1.ebuild')
-rw-r--r--games-board/sirius/sirius-0.8.0-r1.ebuild20
1 files changed, 6 insertions, 14 deletions
diff --git a/games-board/sirius/sirius-0.8.0-r1.ebuild b/games-board/sirius/sirius-0.8.0-r1.ebuild
index 443de7db7aa0..68570c1bc240 100644
--- a/games-board/sirius/sirius-0.8.0-r1.ebuild
+++ b/games-board/sirius/sirius-0.8.0-r1.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=6
-inherit autotools eutils
+
+inherit autotools
DESCRIPTION="A program for playing the game of othello/reversi"
HOMEPAGE="http://sirius.bitvis.nu/"
@@ -25,25 +26,16 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-format.patch
+ "${FILESDIR}"/${P}-fix-desktop-file.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
)
src_prepare() {
default
- sed -i -e '/-g -O3/d' configure.in || die
- sed -i \
- -e '/Icon/s/\.png//' \
- -e '/Categories/s/Application;//' \
- sirius.desktop.in || die
- mv configure.in configure.ac || die
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- econf \
- --datadir=/usr/share \
- $(use_enable nls)
-}
-
-src_install() {
- default
+ econf $(use_enable nls)
}