summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-02-27 19:07:18 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-02-27 19:07:18 -0600
commit0981f6977b0af8e154c33845e5fff0393b34828a (patch)
tree8cafa2b08df0a6f123399ea795f30e11139b794a /games-board/stockfish/stockfish-10.ebuild
parentgames-board/stockfish: remove old versions (diff)
downloadgentoo-0981f6977b0af8e154c33845e5fff0393b34828a.tar.gz
gentoo-0981f6977b0af8e154c33845e5fff0393b34828a.tar.bz2
gentoo-0981f6977b0af8e154c33845e5fff0393b34828a.zip
games-board/stockfish: port to proper cpu_flags_arm use flag
Closes: https://bugs.gentoo.org/694098 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'games-board/stockfish/stockfish-10.ebuild')
-rw-r--r--games-board/stockfish/stockfish-10.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-board/stockfish/stockfish-10.ebuild b/games-board/stockfish/stockfish-10.ebuild
index f507eeb1a674..5974776f35e1 100644
--- a/games-board/stockfish/stockfish-10.ebuild
+++ b/games-board/stockfish/stockfish-10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
general-32 general-64 +optimize"
DEPEND="|| ( app-arch/unzip app-arch/zip )"
@@ -47,7 +47,7 @@ src_compile() {
use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
# other architectures
- use armv7 && my_arch=armv7
+ use cpu_flags_arm_v7 && my_arch=armv7
use ppc && my_arch=ppc
use ppc64 && my_arch=ppc64