summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 01:22:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:30:33 -0400
commit056c458a5ba38ea420d6cbf4f5bc4380e29d7252 (patch)
tree9b8136d350dffcaabb47e6157665516b9499ff3c /games-board
parentgames-arcade/xboing: fix build with clang16 (diff)
downloadgentoo-056c458a5ba38ea420d6cbf4f5bc4380e29d7252.tar.gz
gentoo-056c458a5ba38ea420d6cbf4f5bc4380e29d7252.tar.bz2
gentoo-056c458a5ba38ea420d6cbf4f5bc4380e29d7252.zip
games-board/xgammon: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Closes: https://bugs.gentoo.org/870904 Closes: https://bugs.gentoo.org/871201 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xgammon/xgammon-0.98-r3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-board/xgammon/xgammon-0.98-r3.ebuild b/games-board/xgammon/xgammon-0.98-r3.ebuild
index 6b1305059c62..7d116d14a8e6 100644
--- a/games-board/xgammon/xgammon-0.98-r3.ebuild
+++ b/games-board/xgammon/xgammon-0.98-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
S="${WORKDIR}/${P}a"
@@ -34,7 +35,7 @@ PATCHES=(
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {