summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-06 17:24:00 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-06 22:24:03 -0400
commit0c9e09191f1bf0f9ce1f9055750bc31dd76f31d9 (patch)
treea6e40b876b01ac24ec536f44991a5f27f4f2c0b1 /games-board
parentmedia-gfx/eog: Version bump to 42.3 (diff)
downloadgentoo-0c9e09191f1bf0f9ce1f9055750bc31dd76f31d9.tar.gz
gentoo-0c9e09191f1bf0f9ce1f9055750bc31dd76f31d9.tar.bz2
gentoo-0c9e09191f1bf0f9ce1f9055750bc31dd76f31d9.zip
games-board/tali: Version bump to 40.8
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/tali/Manifest1
-rw-r--r--games-board/tali/tali-40.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/games-board/tali/Manifest b/games-board/tali/Manifest
index 69a6e0b9d03f..93fb3c723cf9 100644
--- a/games-board/tali/Manifest
+++ b/games-board/tali/Manifest
@@ -1 +1,2 @@
DIST tali-40.7.tar.xz 1684740 BLAKE2B ee913a4b0420b7751f26ecdb9805d74811330effb0e3d5e8fa6a4005a5ac410274120ac9c78ec240f062a094c603184c8a237d97b744641d3550db9b2a5a5ea9 SHA512 fc9a13b2d8b37fa5726d99f7ca8bde35b23cd210391d6f4309a0b952d28adc09c3566eb5c88d0dd30b39abbb4abe05ba2f441bad6a8598abfcb1189a3d87cce4
+DIST tali-40.8.tar.xz 1686244 BLAKE2B ad55838f199cce1c5a9b9ff0fa97d8c933900d4917c7339ec3d78f39203802f0ef9b8008a3400a5bddffce62d5ab9daba2af3855ba8bd4c35c69c2fce8984e75 SHA512 fe7a0a0a58c32f09264c270402af94f71e790926bd3f3523d57049628c43bfaf8b0e1ed5c676ef02b817f354d6c3fe183799ee9ff9d7a5e2198e4a4066f3e93a
diff --git a/games-board/tali/tali-40.8.ebuild b/games-board/tali/tali-40.8.ebuild
new file mode 100644
index 000000000000..2a0a7a0e857e
--- /dev/null
+++ b/games-board/tali/tali-40.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Beat the odds in a poker-style dice game"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tali https://gitlab.gnome.org/GNOME/tali"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.16:3
+ dev-libs/libgnome-games-support:1=
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.32:2
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}