summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-21 23:24:50 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-21 23:24:57 +0000
commit2c5ad14317ea5dc717cf2d2766a3fd7c7fe44078 (patch)
treeb5d82be4cbd44f6a0c7a60cb3edd7acec65f3fd3 /games-board
parentnet-libs/nodejs: Depend on >=dev-libs/libuv-1.34.1:= (diff)
downloadgentoo-2c5ad14317ea5dc717cf2d2766a3fd7c7fe44078.tar.gz
gentoo-2c5ad14317ea5dc717cf2d2766a3fd7c7fe44078.tar.bz2
gentoo-2c5ad14317ea5dc717cf2d2766a3fd7c7fe44078.zip
games-board/xboard: tweak for gcc-10
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xboard/files/xboard-4.9.1-gcc-10.patch32
-rw-r--r--games-board/xboard/xboard-4.9.1.ebuild3
2 files changed, 34 insertions, 1 deletions
diff --git a/games-board/xboard/files/xboard-4.9.1-gcc-10.patch b/games-board/xboard/files/xboard-4.9.1-gcc-10.patch
new file mode 100644
index 000000000000..76249036ead3
--- /dev/null
+++ b/games-board/xboard/files/xboard-4.9.1-gcc-10.patch
@@ -0,0 +1,32 @@
+--- a/backend.h
++++ b/backend.h
+@@ -242,7 +242,7 @@ extern GameInfo gameInfo;
+
+ /* ICS vars used with backend.c and zippy.c */
+ enum ICS_TYPE { ICS_GENERIC, ICS_ICC, ICS_FICS, ICS_CHESSNET /* not really supported */ };
+-enum ICS_TYPE ics_type;
++extern enum ICS_TYPE ics_type;
+
+ /* pgntags.c prototypes
+ */
+--- a/evalgraph.h
++++ b/evalgraph.h
+@@ -34,7 +34,7 @@ typedef enum { PEN_NONE, PEN_BLACK, PEN_DOTTED, PEN_BLUEDOTTED, PEN_BOLDWHITE, P
+ #define OPEN 0
+
+ /* Module globals */
+-ChessProgramStats_Move * currPvInfo;
++extern ChessProgramStats_Move * currPvInfo;
+ extern int currFirst;
+ extern int currLast;
+ extern int currCurrent;
+--- a/xaw/xhistory.c
++++ b/xaw/xhistory.c
+@@ -96,7 +96,6 @@ ScrollToCursor (Option *opt, int caretPos)
+
+ // ------------------------------ callbacks --------------------------
+
+-char *historyText;
+ char historyTranslations[] =
+ "<Btn3Down>: select-start() \n \
+ <Btn3Up>: extend-end(PRIMARY) SelectMove() \n";
diff --git a/games-board/xboard/xboard-4.9.1.ebuild b/games-board/xboard/xboard-4.9.1.ebuild
index a2e47ab04728..96d734dff452 100644
--- a/games-board/xboard/xboard-4.9.1.ebuild
+++ b/games-board/xboard/xboard-4.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -43,6 +43,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-4.8.0-gettext.patch
"${FILESDIR}"/${PN}-4.8.0-gnuchess-default.patch
+ "${FILESDIR}"/${PN}-4.9.1-gcc-10.patch
)
DOCS=( AUTHORS COPYRIGHT ChangeLog FAQ.html NEWS README TODO ics-parsing.txt )