summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 09:59:34 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:24:45 +0200
commit44e18c195d8d743b71d09b7a9787e9ee79019e90 (patch)
tree2fe0de4d9b683c80cded9b44afb4125d521bd98b /games-board
parentgames-board/crafty: Drop old (diff)
downloadgentoo-44e18c195d8d743b71d09b7a9787e9ee79019e90.tar.gz
gentoo-44e18c195d8d743b71d09b7a9787e9ee79019e90.tar.bz2
gentoo-44e18c195d8d743b71d09b7a9787e9ee79019e90.zip
games-board/fruit: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-board')
-rw-r--r--games-board/fruit/files/fruit-2.1-gentoo.patch4
-rw-r--r--games-board/fruit/fruit-2.1-r1.ebuild41
2 files changed, 43 insertions, 2 deletions
diff --git a/games-board/fruit/files/fruit-2.1-gentoo.patch b/games-board/fruit/files/fruit-2.1-gentoo.patch
index bae207f89627..815b184d9dc2 100644
--- a/games-board/fruit/files/fruit-2.1-gentoo.patch
+++ b/games-board/fruit/files/fruit-2.1-gentoo.patch
@@ -1,5 +1,5 @@
---- option.cpp.old 2007-02-07 23:32:25.000000000 +0100
-+++ option.cpp 2007-02-07 23:32:51.000000000 +0100
+--- a/option.cpp.old 2007-02-07 23:32:25.000000000 +0100
++++ b/option.cpp 2007-02-07 23:32:51.000000000 +0100
@@ -29,7 +29,7 @@
{ "Ponder", true, "false", "check", "", NULL },
diff --git a/games-board/fruit/fruit-2.1-r1.ebuild b/games-board/fruit/fruit-2.1-r1.ebuild
new file mode 100644
index 000000000000..bb8f7635cf15
--- /dev/null
+++ b/games-board/fruit/fruit-2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit versionator
+
+MY_PV="$(replace_all_version_separators '')"
+MY_P="${PN}_${MY_PV}_linux"
+
+DESCRIPTION="UCI-only chess engine"
+HOMEPAGE="http://arctrix.com/nas/fruit/"
+SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}/src"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ option.cpp || die
+ sed -i \
+ -e '/^CXX/d' \
+ -e '/^LDFLAGS/d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto "/usr/share/${PN}"
+ doins ../book_small.bin
+ dodoc ../readme.txt ../technical_10.txt
+}