summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 11:35:32 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-08 12:25:06 -0500
commitb11b60745c13868beb102818a7eb12d160c10ffa (patch)
tree5b601fa689351f91063df6d97976cf7754b47b8f /games-board
parentsys-kernel/hardened-sources: version bump to 4.7.3 (diff)
downloadgentoo-b11b60745c13868beb102818a7eb12d160c10ffa.tar.gz
gentoo-b11b60745c13868beb102818a7eb12d160c10ffa.tar.bz2
gentoo-b11b60745c13868beb102818a7eb12d160c10ffa.zip
games-board/biloba: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/biloba/biloba-0.9.3-r1.ebuild52
-rw-r--r--games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch4
-rw-r--r--games-board/biloba/files/biloba-0.9.3-not-windows.patch4
3 files changed, 56 insertions, 4 deletions
diff --git a/games-board/biloba/biloba-0.9.3-r1.ebuild b/games-board/biloba/biloba-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..6d830fca4c15
--- /dev/null
+++ b/games-board/biloba/biloba-0.9.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="a board game, up to 4 players, with AI and network"
+HOMEPAGE="http://biloba.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[X,video,sound]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ # X11 headers are checked but not used, everything is done through SDL
+ "${FILESDIR}"/${P}-not-windows.patch
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+)
+
+src_prepare() {
+ default
+
+ # "missing" file is old, and warns about --run not being supported
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon -s 64 biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch b/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
index 4c4ef50776cb..adc8395a947d 100644
--- a/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
+++ b/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2006-07-29 11:38:43.000000000 +0200
-+++ configure.ac 2006-07-29 11:40:52.000000000 +0200
+--- a/configure.ac 2006-07-29 11:38:43.000000000 +0200
++++ b/configure.ac 2006-07-29 11:40:52.000000000 +0200
@@ -40,14 +40,6 @@
;;
*)
diff --git a/games-board/biloba/files/biloba-0.9.3-not-windows.patch b/games-board/biloba/files/biloba-0.9.3-not-windows.patch
index c0ed069ffc2d..035685cfafef 100644
--- a/games-board/biloba/files/biloba-0.9.3-not-windows.patch
+++ b/games-board/biloba/files/biloba-0.9.3-not-windows.patch
@@ -1,5 +1,5 @@
---- configure.ac.old 2008-01-14 14:51:11.000000000 +0100
-+++ configure.ac 2008-12-28 12:57:13.000000000 +0100
+--- a/configure.ac 2008-01-14 14:51:11.000000000 +0100
++++ b/configure.ac 2008-12-28 12:57:13.000000000 +0100
@@ -73,12 +65,6 @@
AC_MSG_ERROR([*** SDL-Mixer not found!]))
AC_CHECK_HEADER(SDL/SDL_mixer.h, , AC_MSG_ERROR([*** SDL-mixer devel files not found!]))