summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-04-27 22:49:39 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-04-27 22:49:39 +0100
commitb1e9b981d868caa32a59110e89eda03bafcbe155 (patch)
tree2f2d2b3b539ba7c8bc4dcfb8c8574136a8c69832 /games-board
parentapp-text/libwps: 0.4.9 version bump (diff)
downloadgentoo-b1e9b981d868caa32a59110e89eda03bafcbe155.tar.gz
gentoo-b1e9b981d868caa32a59110e89eda03bafcbe155.tar.bz2
gentoo-b1e9b981d868caa32a59110e89eda03bafcbe155.zip
games-board/pokerth: Version bump to 1.1.2
Fixes protobuf issue. Some libraries still need unbundling. Closes: https://bugs.gentoo.org/644460 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/Manifest1
-rw-r--r--games-board/pokerth/files/pokerth-1.1.2-protobuf.patch23
-rw-r--r--games-board/pokerth/pokerth-1.1.2.ebuild71
3 files changed, 95 insertions, 0 deletions
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
index bb54b52e7041..75c22499163e 100644
--- a/games-board/pokerth/Manifest
+++ b/games-board/pokerth/Manifest
@@ -1 +1,2 @@
DIST PokerTH-1.1.1-src.tar.bz2 19326922 BLAKE2B 43c94c1330ca11eaa52e4729e52fed3ee4022b8486b626168933a20658bf0c79028adb39b68433e5ccb7c8618b610366f193720f821039adc0e9a84eff0488b7 SHA512 bd822d15747d94b67657ea2fd0b9c8c1bdad0031a6eae30380217387a702e5f648d6f612b1bff0355c3c301ecaf47ca9d635a526e575f1bc1c5f88e38a7f73c1
+DIST pokerth-1.1.2.tar.gz 21354306 BLAKE2B d8e1ecc46e61d9c16ae3949099f6e72271a5ab2def9799652b0c612980e0c5e96cb2ccf4d659c1a90b9ac6433af95587fa5d44af80c16fb6a34a272751c9fc4a SHA512 d54c84f199636eb5a53580213e5e4ccc828cf565bf4b055797daa82e2ad54d8c52c7a16a781b82c8cc89d184a2b3c4105922394d08c7d2e06383b96963c36b5a
diff --git a/games-board/pokerth/files/pokerth-1.1.2-protobuf.patch b/games-board/pokerth/files/pokerth-1.1.2-protobuf.patch
new file mode 100644
index 000000000000..0ac2ab0b1531
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.2-protobuf.patch
@@ -0,0 +1,23 @@
+https://github.com/pokerth/pokerth/issues/339
+--- PokerTH-1.1.1-src/pokerth.proto
++++ PokerTH-1.1.1-src.new/pokerth.proto
+@@ -701,7 +701,7 @@
+
+ message ErrorMessage {
+ enum ErrorReason {
+- reserved = 0;
++ custReserved = 0;
+ initVersionNotSupported = 1;
+ initServerFull = 2;
+ initAuthFailure = 3;
+--- PokerTH-1.1.1-src/src/net/common/netpacket.cpp
++++ PokerTH-1.1.1-src.new/src/net/common/netpacket.cpp
+@@ -249,7 +249,7 @@
+ retVal = ErrorMessage::sessionTimeout;
+ break;
+ default :
+- retVal = ErrorMessage::reserved;
++ retVal = ErrorMessage::custReserved;
+ break;
+ }
+ return retVal;
diff --git a/games-board/pokerth/pokerth-1.1.2.ebuild b/games-board/pokerth/pokerth-1.1.2.ebuild
new file mode 100644
index 000000000000..3a84288bbc76
--- /dev/null
+++ b/games-board/pokerth/pokerth-1.1.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils qmake-utils
+
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="https://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/boost:0=[threads(+)]
+ dev-libs/libgcrypt:0
+ dev-libs/protobuf:0=
+ dev-libs/tinyxml[stl]
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ >=net-libs/libircclient-1.6-r2
+ >=net-misc/curl-7.16
+ virtual/gsasl
+ !dedicated? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl:0
+ media-libs/sdl-mixer[mod,vorbis]
+ )"
+DEPEND="${RDEPEND}
+ !dedicated? ( dev-qt/qtsql:5 )
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${P}-rc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-boost-1.65-ambiguous-advance.patch
+ "${FILESDIR}"/${PN}-1.1.2-protobuf.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's/!client//' *.pro || die
+}
+
+src_configure() {
+ eqmake5 pokerth.pro \
+ QMAKE_CFLAGS_ISYSTEM= \
+ CONFIG+="$(use dedicated || echo client)"
+}
+
+src_install() {
+ dobin bin/pokerth_server chatcleaner
+ dodoc docs/{gui_styling,server_setup}_howto.txt
+ doman docs/pokerth.1
+
+ if ! use dedicated; then
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r data
+ domenu ${PN}.desktop
+ doicon -s 128 ${PN}.png
+ fi
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }