summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-28 10:12:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-28 12:42:39 -0400
commite2d347fd03422da521dd933def9982f63b5b889f (patch)
tree9e0e87d0f522e6559fa4190df9cd3d4cbdadd5ac /games-board
parentgames-board/camato: EAPI 6->7, versionator--, remove homepage (diff)
downloadgentoo-e2d347fd03422da521dd933def9982f63b5b889f.tar.gz
gentoo-e2d347fd03422da521dd933def9982f63b5b889f.tar.bz2
gentoo-e2d347fd03422da521dd933def9982f63b5b889f.zip
games-board/fruit: EAPI 6->8, versionator--, prefix/cxx fix
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/fruit/files/fruit-2.1-gentoo.patch11
-rw-r--r--games-board/fruit/fruit-2.1-r1.ebuild43
2 files changed, 20 insertions, 34 deletions
diff --git a/games-board/fruit/files/fruit-2.1-gentoo.patch b/games-board/fruit/files/fruit-2.1-gentoo.patch
deleted file mode 100644
index 815b184d9dc2..000000000000
--- a/games-board/fruit/files/fruit-2.1-gentoo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/option.cpp.old 2007-02-07 23:32:25.000000000 +0100
-+++ b/option.cpp 2007-02-07 23:32:51.000000000 +0100
-@@ -29,7 +29,7 @@
- { "Ponder", true, "false", "check", "", NULL },
-
- { "OwnBook", true, "true", "check", "", NULL },
-- { "BookFile", true, "book_small.bin", "string", "", NULL },
-+ { "BookFile", true, "@GENTOO_DATADIR@/book_small.bin", "string", "", NULL },
-
- { "NullMove Pruning", true, "Fail High", "combo", "var Always var Fail High var Never", NULL },
- { "NullMove Reduction", true, "3", "spin", "min 1 max 3", NULL },
diff --git a/games-board/fruit/fruit-2.1-r1.ebuild b/games-board/fruit/fruit-2.1-r1.ebuild
index bb8f7635cf15..4794f6bf817f 100644
--- a/games-board/fruit/fruit-2.1-r1.ebuild
+++ b/games-board/fruit/fruit-2.1-r1.ebuild
@@ -1,41 +1,38 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit versionator
+EAPI=8
-MY_PV="$(replace_all_version_separators '')"
-MY_P="${PN}_${MY_PV}_linux"
+inherit toolchain-funcs
+
+MY_P="${PN}_$(ver_rs 1- '')_linux"
DESCRIPTION="UCI-only chess engine"
-HOMEPAGE="http://arctrix.com/nas/fruit/"
-SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
+HOMEPAGE="https://arctrix.com/nas/fruit/"
+SRC_URI="https://arctrix.com/nas/${PN}/${MY_P}.zip"
+S="${WORKDIR}/${MY_P}/src"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}/${MY_P}/src"
+BDEPEND="app-arch/unzip"
src_prepare() {
default
- eapply "${FILESDIR}/${P}"-gentoo.patch
- sed -i \
- -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
- option.cpp || die
- sed -i \
- -e '/^CXX/d' \
- -e '/^LDFLAGS/d' \
- Makefile || die
+
+ sed -i "s|book_small|${EPREFIX}/usr/share/${PN}/book_small|" option.cpp || die
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
dobin ${PN}
- insinto "/usr/share/${PN}"
+
+ insinto /usr/share/${PN}
doins ../book_small.bin
- dodoc ../readme.txt ../technical_10.txt
+
+ dodoc ../{readme,technical_10}.txt
}