summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-22 15:02:04 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-22 15:06:59 +0300
commitecd15944db5a9d379b286f8a2c997755796914a0 (patch)
tree4fadd0feb8079cd6ea9ae6d26e65ec1dacfd053b /games-board
parentgnome-extra/gnome-weather: bump to 3.36.1 (diff)
downloadgentoo-ecd15944db5a9d379b286f8a2c997755796914a0.tar.gz
gentoo-ecd15944db5a9d379b286f8a2c997755796914a0.tar.bz2
gentoo-ecd15944db5a9d379b286f8a2c997755796914a0.zip
games-board/gnome-chess: bump to 3.36.1
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-3.36.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 6e768cae226c..d4eaacf0c362 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-3.34.0.tar.xz 648464 BLAKE2B c06474fbdaeb9dfc26fbadaa6f5dc83179cdc6d09b8007b2dfcd88a4af4a6113913cffa8f00ada7a788585d723c5917f7ad7944bf466411119e7979545f40f29 SHA512 dcd4c2cfb0ebb5d3481bb6f722ac847cb8976e31352286a245457a62291445f50ad86ce26a37c222112801dc807bb567ed4d71d2d6ccb1628c2cab0767445012
+DIST gnome-chess-3.36.1.tar.xz 738308 BLAKE2B 14d328b9939afb12f14b513cfa009e3fb197f6c35c5272df107ce844890339caecbb5dafbd0bd28a19d001ebc0574464b33ea2ca10a9f7578b49d1e6f637e190 SHA512 4c89f91fe16323a799cf1eb3fe1f8e37fd506248ca32ad605ca3d5ecd37cf29f046da50383e0d0c3d82acf4e472843f3fd40927283f37e02d42cee5d8c72d8b3
diff --git a/games-board/gnome-chess/gnome-chess-3.36.1.ebuild b/games-board/gnome-chess/gnome-chess-3.36.1.ebuild
new file mode 100644
index 000000000000..78cac2a1a480
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.36.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20.0:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}