summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-02 20:37:37 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-02 20:38:11 +0200
commitfe21daa00cecd075617683145692cde6319c6654 (patch)
tree80ddc7f382e884ae64013860182c17f630b7f787 /games-board
parentsys-apps/baselayout: stabilize 2.4.1-r2 for #631510 (diff)
downloadgentoo-fe21daa00cecd075617683145692cde6319c6654.tar.gz
gentoo-fe21daa00cecd075617683145692cde6319c6654.tar.bz2
gentoo-fe21daa00cecd075617683145692cde6319c6654.zip
games-board/qgo: Fix narrowing conversion error, bug 598406
Closes: https://bugs.gentoo.org/598406 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'games-board')
-rw-r--r--games-board/qgo/files/qgo-1.5.4_p20100322-gcc6.patch12
-rw-r--r--games-board/qgo/qgo-1.5.4_p20100322-r1.ebuild3
-rw-r--r--games-board/qgo/qgo-1.5.4_p20100322.ebuild5
3 files changed, 17 insertions, 3 deletions
diff --git a/games-board/qgo/files/qgo-1.5.4_p20100322-gcc6.patch b/games-board/qgo/files/qgo-1.5.4_p20100322-gcc6.patch
new file mode 100644
index 000000000000..52b4ec2faaf4
--- /dev/null
+++ b/games-board/qgo/files/qgo-1.5.4_p20100322-gcc6.patch
@@ -0,0 +1,12 @@
+diff -ruN qgo-1.5.4_p20100322.orig/src/network/cyberoroconnection.cpp qgo-1.5.4_p20100322/src/network/cyberoroconnection.cpp
+--- qgo-1.5.4_p20100322.orig/src/network/cyberoroconnection.cpp 2010-02-26 19:43:41.000000000 +0100
++++ qgo-1.5.4_p20100322/src/network/cyberoroconnection.cpp 2017-10-02 20:33:32.661506058 +0200
+@@ -534,7 +534,7 @@
+ }
+
+ // this is the initial packet
+- char packet[8] = { 0x0a, 0xfa, 0x08, 0x00, 0x00, 0x00, 0x00, 0x00 };
++ unsigned char packet[8] = { 0x0a, 0xfa, 0x08, 0x00, 0x00, 0x00, 0x00, 0x00 };
+ if(write((const char *)packet, 8) < 0)
+ qWarning("*** failed sending init packet to reconnected host");
+ return 0;
diff --git a/games-board/qgo/qgo-1.5.4_p20100322-r1.ebuild b/games-board/qgo/qgo-1.5.4_p20100322-r1.ebuild
index fa8cca440e9a..7c65e182f470 100644
--- a/games-board/qgo/qgo-1.5.4_p20100322-r1.ebuild
+++ b/games-board/qgo/qgo-1.5.4_p20100322-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc45.patch
"${FILESDIR}"/${P}-qt47.patch
"${FILESDIR}"/${P}-buffer.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_prepare() {
diff --git a/games-board/qgo/qgo-1.5.4_p20100322.ebuild b/games-board/qgo/qgo-1.5.4_p20100322.ebuild
index 26945ecb19f6..e0a6618cbb4a 100644
--- a/games-board/qgo/qgo-1.5.4_p20100322.ebuild
+++ b/games-board/qgo/qgo-1.5.4_p20100322.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,7 +33,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gcc45.patch \
"${FILESDIR}"/${P}-qt47.patch \
- "${FILESDIR}"/${P}-buffer.patch
+ "${FILESDIR}"/${P}-buffer.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
}
src_configure() {