summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/dboxfe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/dboxfe')
-rw-r--r--games-emulation/dboxfe/Manifest1
-rw-r--r--games-emulation/dboxfe/dboxfe-0.1.3.ebuild36
-rw-r--r--games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch20
-rw-r--r--games-emulation/dboxfe/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/games-emulation/dboxfe/Manifest b/games-emulation/dboxfe/Manifest
new file mode 100644
index 000000000000..b1712472eb2b
--- /dev/null
+++ b/games-emulation/dboxfe/Manifest
@@ -0,0 +1 @@
+DIST dboxfe-0.1.3.tar.bz2 260934 SHA256 a1e8e2fa1b3221f3e7dc14c065e93eede3b9d744d94047118cc730207eb52c5c SHA512 2c4f56b03daa4701b1c28c6082c89cb5e737c2d808215ea994ecbaf18d7e02a5616291b229768a86e4ff272e4d84fffaf4ec3350efad72b4f6aa6195804a7ad2 WHIRLPOOL 77e49f802912a67e07f3c9e81ff5d352f9a9c53741e711e9774acb98fb3cd4075dea5eac317c8b10bde941e6fd6d53ae17ceaf2115d35e28a37f953ae41757a0
diff --git a/games-emulation/dboxfe/dboxfe-0.1.3.ebuild b/games-emulation/dboxfe/dboxfe-0.1.3.ebuild
new file mode 100644
index 000000000000..71f9204bcbae
--- /dev/null
+++ b/games-emulation/dboxfe/dboxfe-0.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2 games
+
+DESCRIPTION="Creates and manages configuration files for DOSBox"
+HOMEPAGE="http://sourceforge.net/projects/dboxfe.berlios/"
+SRC_URI="mirror://sourceforge/dboxfe.berlios/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtcore:4"
+RDEPEND="${DEPEND}
+ >=games-emulation/dosbox-0.65"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ dogamesbin bin/dboxfe
+ dodoc TODO ChangeLog
+ newicon res/default.png ${PN}.png
+ make_desktop_entry dboxfe "DosBoxFE"
+ prepgamesdirs
+}
diff --git a/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch b/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
new file mode 100644
index 000000000000..6ceb1d2d5c29
--- /dev/null
+++ b/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
@@ -0,0 +1,20 @@
+--- dboxfe.pro.old 2010-09-29 23:53:38.000000000 +0200
++++ dboxfe.pro 2010-09-29 23:54:11.000000000 +0200
+@@ -83,6 +83,7 @@
+ # Unix/Linux settings
+ unix{
+ TARGET = dboxfe
++ QMAKE_LFLAGS += $(LDFLAGS)
+ #QMAKE_POST_LINK = strip -s bin/dboxfe
+ RCC_DIR = .unix/rcc
+ MOC_DIR += .unix/moc
+--- dboxfetray/dboxfetray.pro.old 2010-09-29 23:55:31.000000000 +0200
++++ dboxfetray/dboxfetray.pro 2010-09-29 23:56:12.000000000 +0200
+@@ -56,6 +56,7 @@
+ # Unix/Linux settings
+ unix{
+ TARGET = dboxfetray
++ QMAKE_LFLAGS += $(LDFLAGS)
+ #QMAKE_POST_LINK = strip -s bin/dboxfetray
+ RCC_DIR = .unix/rcc
+ MOC_DIR += .unix/moc
diff --git a/games-emulation/dboxfe/metadata.xml b/games-emulation/dboxfe/metadata.xml
new file mode 100644
index 000000000000..921785cff2d7
--- /dev/null
+++ b/games-emulation/dboxfe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">dboxfe.berlios</remote-id>
+ </upstream>
+</pkgmetadata>