summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/desmume
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/desmume')
-rw-r--r--games-emulation/desmume/Manifest3
-rw-r--r--games-emulation/desmume/desmume-0.9.10.ebuild40
-rw-r--r--games-emulation/desmume/desmume-0.9.8.ebuild36
-rw-r--r--games-emulation/desmume/desmume-0.9.9.ebuild36
-rw-r--r--games-emulation/desmume/files/desmume-fix-function-type.patch22
-rw-r--r--games-emulation/desmume/metadata.xml11
6 files changed, 148 insertions, 0 deletions
diff --git a/games-emulation/desmume/Manifest b/games-emulation/desmume/Manifest
new file mode 100644
index 000000000000..764c4739fabe
--- /dev/null
+++ b/games-emulation/desmume/Manifest
@@ -0,0 +1,3 @@
+DIST desmume-0.9.10.tar.gz 4141586 SHA256 8900a7a1fc849fdd33b014748dd97a6cda4c32548b8d2e06511e6ed8d5ba7445 SHA512 a9151f1d8b08ce64a837ae2447221f5c0003286d4c75b9416d5f151627755aafb09a5120c39b8ee39a04b99d9e8c49ac7dcc0ccd083507aab7e4801269468012 WHIRLPOOL e924adf532db2b10691cb01640f1dbf54045b0dbe6c5daf59c0150a2b254c86cd8d384bc364fdb756168599319a1ef81ce751f09cd5d5e5b79980fb26b9a4e72
+DIST desmume-0.9.8.tar.gz 3677290 SHA256 78363468a2d5efba95de57739a9c81a3757ecd76c2a183ec68336e30d47a5e01
+DIST desmume-0.9.9.tar.gz 4107513 SHA256 cd2ad70cdde1236eba5a4ff8cea838f42b7dc470e32ac938263f49f12a55d754 SHA512 ba5a965102559f048cd57718b4c50e6b2bd39eca4a5990e4cdf068bfa752fccb52d71911ea48da769c5ec18bb740f6b09e6c856ccc78b1e1adf23fd701d1fe31 WHIRLPOOL 055594100216e4ffd046119716e9acc018e7631f96f2be4e830495f88462382180c3955841bfcc3ec494227a606bc820820342907e2b1b2b61a8a65f9b1949b4
diff --git a/games-emulation/desmume/desmume-0.9.10.ebuild b/games-emulation/desmume/desmume-0.9.10.ebuild
new file mode 100644
index 000000000000..b761c4276035
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit games
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.8.0:2
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick]
+ x11-libs/agg"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/desmume-fix-function-type.patch"
+}
+
+src_configure() {
+ egamesconf --datadir=/usr/share
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README README.LIN
+ prepgamesdirs
+}
diff --git a/games-emulation/desmume/desmume-0.9.8.ebuild b/games-emulation/desmume/desmume-0.9.8.ebuild
new file mode 100644
index 000000000000..942cb36b5da1
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit games
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.8.0:2
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick]
+ x11-libs/agg"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ egamesconf --datadir=/usr/share || die "egamesconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog README README.LIN
+ prepgamesdirs
+}
diff --git a/games-emulation/desmume/desmume-0.9.9.ebuild b/games-emulation/desmume/desmume-0.9.9.ebuild
new file mode 100644
index 000000000000..73d2ad571cac
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit games
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.8.0:2
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick]
+ x11-libs/agg"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ egamesconf --datadir=/usr/share || die "egamesconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog README README.LIN
+ prepgamesdirs
+}
diff --git a/games-emulation/desmume/files/desmume-fix-function-type.patch b/games-emulation/desmume/files/desmume-fix-function-type.patch
new file mode 100644
index 000000000000..b370d57912eb
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-fix-function-type.patch
@@ -0,0 +1,22 @@
+diff -Naur a/src/gtk/glx_3Demu.cpp b/src/gtk/glx_3Demu.cpp
+--- a/src/gtk/glx_3Demu.cpp 2014-12-06 21:08:12.628393543 +0100
++++ b/src/gtk/glx_3Demu.cpp 2014-12-06 21:08:26.591393054 +0100
+@@ -31,7 +31,7 @@
+ static GLXContext ctx;
+ static GLXPbuffer pbuf;
+
+-void deinit_glx_3Demu(void)
++int deinit_glx_3Demu(void)
+ {
+ Display *dpy = glXGetCurrentDisplay();
+
+diff -Naur a/src/gtk/glx_3Demu.h b/src/gtk/glx_3Demu.h
+--- a/src/gtk/glx_3Demu.h 2014-12-06 21:08:12.628393543 +0100
++++ b/src/gtk/glx_3Demu.h 2014-12-06 21:08:23.999393145 +0100
+@@ -20,5 +20,5 @@
+
+ #ifdef HAVE_GL_GLX
+ int init_glx_3Demu(void);
+-void deinit_glx_3Demu(void);
++int deinit_glx_3Demu(void);
+ #endif
diff --git a/games-emulation/desmume/metadata.xml b/games-emulation/desmume/metadata.xml
new file mode 100644
index 000000000000..c36000ab7b2e
--- /dev/null
+++ b/games-emulation/desmume/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">desmume</remote-id>
+ </upstream>
+</pkgmetadata>