summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 11:08:11 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:13 +0200
commit9f5bb989f4ec5a6c5f742dc340bf7cf8a78bdf63 (patch)
tree4ba7c02561271c8caa7413db5d2064b4e700a32b /games-emulation/dgen-sdl
parentgames-emulation/daphne: Prepare patches for future use of eapply (diff)
downloadgentoo-9f5bb989f4ec5a6c5f742dc340bf7cf8a78bdf63.tar.gz
gentoo-9f5bb989f4ec5a6c5f742dc340bf7cf8a78bdf63.tar.bz2
gentoo-9f5bb989f4ec5a6c5f742dc340bf7cf8a78bdf63.zip
games-emulation/dgen-sdl: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation/dgen-sdl')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild40
-rw-r--r--games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch4
2 files changed, 42 insertions, 2 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
new file mode 100644
index 000000000000..5d9acdc094b9
--- /dev/null
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+HOMEPAGE="http://dgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dgen/files/${P}.tar.gz"
+
+LICENSE="dgen-sdl BSD BSD-2 free-noncomm LGPL-2.1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick opengl"
+
+RDEPEND="
+ media-libs/libsdl[joystick?,opengl?]
+ app-arch/libarchive
+ opengl? ( virtual/opengl )
+"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-joystick.patch )
+
+src_configure() {
+ econf \
+ $(use_enable x86 asm) \
+ $(use_enable joystick) \
+ $(use_enable opengl)
+}
+
+src_compile() {
+ emake -C musa m68kops.h
+ emake
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+}
diff --git a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch
index 38cb962b690b..6cb4e936b35b 100644
--- a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch
+++ b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch
@@ -1,5 +1,5 @@
---- sdl/sdl.cpp.orig
-+++ sdl/sdl.cpp
+--- a/sdl/sdl.cpp.orig
++++ b/sdl/sdl.cpp
@@ -6285,6 +6285,7 @@
#endif
static unsigned long hide_mouse_when;