summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-02-14 12:21:09 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-02-14 12:21:09 +0000
commitda178bdead5d0db0310504d979ebeac17377f81c (patch)
treef09662c3adee36346ce598dd9d9672ecfcdf1ed6 /games-emulation/dosbox/files
parentdev-lang/elixir: drop old (diff)
downloadgentoo-da178bdead5d0db0310504d979ebeac17377f81c.tar.gz
gentoo-da178bdead5d0db0310504d979ebeac17377f81c.tar.bz2
gentoo-da178bdead5d0db0310504d979ebeac17377f81c.zip
games-emulation/dosbox: Update ncurses patch for latest trunk
Closes: https://bugs.gentoo.org/760642 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-emulation/dosbox/files')
-rw-r--r--games-emulation/dosbox/files/dosbox-0.75-ncurses.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/games-emulation/dosbox/files/dosbox-0.75-ncurses.patch b/games-emulation/dosbox/files/dosbox-0.75-ncurses.patch
new file mode 100644
index 000000000000..67c23c70532a
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.75-ncurses.patch
@@ -0,0 +1,78 @@
+https://sourceforge.net/p/dosbox/patches/286/
+
+--- a/configure.ac 2019-11-12 17:55:51.000000000 +0000
++++ b/configure.ac 2020-01-02 21:26:27.551856431 +0000
+@@ -235,39 +235,41 @@
+ #Features to enable/disable
+ AH_TEMPLATE(C_DEBUG,[Define to 1 to enable internal debugger, requires libcurses])
+ AH_TEMPLATE(C_HEAVY_DEBUG,[Define to 1 to enable heavy debugging, also have to enable C_DEBUG])
+-AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),[
+- AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
+- AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
+- AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
+- AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),,enable_debug=no)
++AC_MSG_CHECKING(whether debug will be enabled)
++
++if test x$enable_debug = xno; then
++ AC_MSG_RESULT(no)
++else
++ AC_MSG_RESULT(yes)
+
+- if test x$enable_debug = xno; then
+- AC_MSG_RESULT([Debugger not enabled])
+- elif test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lncurses"
+- if test x$host = xi386-pc-os2-emx ; then
+- LIBS="$LIBS -ltinfo"
+- fi
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lpdcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- else
+- AC_MSG_ERROR([Can't find curses, which is required for debug mode])
+- fi
+-],)
++ PKG_CHECK_MODULES(NCURSES, ncurses, [
++ LIBS="$LIBS $NCURSES_LIBS"; CFLAGS="$CFLAGS $NCURSES_CFLAGS"
++ ], [
++ AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
++ AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
++ AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
++ AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++
++ if test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lncurses"
++ if test x$host = xi386-pc-os2-emx ; then
++ LIBS="$LIBS -ltinfo"
++ fi
++ elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lcurses"
++ elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lpdcurses"
++ else
++ AC_MSG_ERROR([Can't find curses, which is required for debug mode])
++ fi
++ ])
++
++ AC_DEFINE(C_DEBUG,1)
++ if test x$enable_debug = xheavy; then
++ AC_DEFINE(C_HEAVY_DEBUG,1)
++ fi
++fi
+
+ AH_TEMPLATE(C_CORE_INLINE,[Define to 1 to use inlined memory functions in cpu core])
+ AC_ARG_ENABLE(core-inline,AC_HELP_STRING([--disable-core-inline],[Disable inlined memory handling in CPU Core]),,enable_core_inline=yes)