summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-02 20:43:32 -0500
committerJames Le Cuirot <chewi@gentoo.org>2018-08-27 22:16:15 +0100
commit85efdc28e53232143b851da4e274889e01f9876c (patch)
treebf5a487ce78ebda9b5eac9de18fe22b6d61bba9f /games-emulation/dosbox
parentnet-print/c2esp: Drop old 25c (diff)
downloadgentoo-85efdc28e53232143b851da4e274889e01f9876c.tar.gz
gentoo-85efdc28e53232143b851da4e274889e01f9876c.tar.bz2
gentoo-85efdc28e53232143b851da4e274889e01f9876c.zip
games-emulation/dosbox: eutils->desktop
Only has eutils for the implicit desktop inheritance for doicon and make_desktop_entry. Package-Manager: Portage-2.3.44, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9429
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild7
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629.ebuild7
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
index f622d980d347..d7fd016f2ca3 100644
--- a/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils flag-o-matic
+
+inherit autotools desktop flag-o-matic
PATCH=3989
GLIDE_PATCH=3722fc563b737d2d7933df6a771651c2154e6f7b
@@ -31,7 +32,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
PATCHES=(
-"${FILESDIR}"/dosbox-0.74-gcc46.patch
+ "${FILESDIR}"/${PN}-0.74-gcc46.patch
)
src_prepare() {
diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
index 45b0b0fdb711..a7b41d8d34ea 100644
--- a/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils
+
+inherit autotools desktop
PATCH=3989
DESCRIPTION="DOS emulator"
@@ -27,7 +28,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
PATCHES=(
-"${FILESDIR}"/dosbox-0.74-gcc46.patch
+ "${FILESDIR}"/${PN}-0.74-gcc46.patch
)
src_prepare() {
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index bceaab9e8150..786b1f786887 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools desktop flag-o-matic
+
GLIDE_PATCH=841e1071597b64ead14dd08c25a03206b2d1d1b6
SRC_URI="glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
@@ -14,8 +16,6 @@ else
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
fi
-inherit autotools eutils flag-o-matic
-
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
@@ -37,7 +37,9 @@ if [[ ${PV} = 9999 ]]; then
S=${WORKDIR}/${PN}
fi
-PATCHES=( "${FILESDIR}/${PN}-0.74-gcc46.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.74-gcc46.patch
+)
src_prepare() {
use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff