summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-01-01 13:56:15 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-01-01 22:56:03 +0000
commitcbf26e890327dabc3a96b1b7aa2ce98a6424aeb2 (patch)
tree0a1128f9cec9d4d6bab5b7bc07cdee03a7fc093b /games-emulation/dosbox
parentgames-emulation/dosbox: EAPI 7 and clean up for 9999 (diff)
downloadgentoo-cbf26e890327dabc3a96b1b7aa2ce98a6424aeb2.tar.gz
gentoo-cbf26e890327dabc3a96b1b7aa2ce98a6424aeb2.tar.bz2
gentoo-cbf26e890327dabc3a96b1b7aa2ce98a6424aeb2.zip
games-emulation/dosbox: Add version 0.74.3
Despite being released in 2019, this is actually older than our 2016 snapshot in some respects as it was not cut from trunk. It does include important security fixes though. It does not include Glide support as that will not build. Bug: https://bugs.gentoo.org/704414 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/Manifest1
-rw-r--r--games-emulation/dosbox/dosbox-0.74.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/games-emulation/dosbox/Manifest b/games-emulation/dosbox/Manifest
index 7f4c5a65201c..a06402a5d873 100644
--- a/games-emulation/dosbox/Manifest
+++ b/games-emulation/dosbox/Manifest
@@ -1,3 +1,4 @@
+DIST dosbox-0.74-3.tar.gz 1326339 BLAKE2B bc25e6aba29747d4060269809d729904d8d187527c59953125c8591c0a91cf4583223c1bcf1224a041d44bfe5efcfe9034d6572954cf26870a290ff1b27e7d9d SHA512 3770f1578e71730168fba01809585f2a05cf8c4d420524687ba28791d242faad294401bb9cd268bba725798e1db853551f274dc00a4024331f5dcef9f87f8f5f
DIST dosbox-code-0-3989-dosbox-trunk.zip 1327592 BLAKE2B 7a9eccd381c1ce7a08d6e650d94de9e82aa5fb1b63abd23b0f42d10d95df4ca2ba4b2c319f3375e030c1578f032ee7bde528f9c4bbc27b665733f7d035865376 SHA512 625eacc1a1190d87d56713f7af54e6a7886e7666ba9f7f0b1d553c96a2eb02ec7810ac2da73d014d5ea3b69f2a7658bdd445532abe030e7f6ef85a3c20bdd3c7
DIST dosbox_glide-3722fc563b737d2d7933df6a771651c2154e6f7b.diff 96346 BLAKE2B c22d8897b3767b3351aec4d7bd64d201c32e2191c0520478f33973b0b36652e9770f571ea32fee6d30a4de35cae1c4d223d56af070b3f3916f6827ab47ec0585 SHA512 d2be6ee8bd1f13058c76ccae595b67f15ab87e0e36dab0d938ebbd7fc5d379f6f054d30c32ef4723b9fcdbbcea7bf0e1aa2c8b1aab1737f1d0e4d2a2df0f7714
DIST dosbox_glide-841e1071597b64ead14dd08c25a03206b2d1d1b6.diff 96801 BLAKE2B d24d1f4262129899d807c275b1ae2d6c09056a126441665f37359302428f30576f399c4778b55f4eaec674e714d85243f576bfa3064887c5801daddc9e507aad SHA512 4cbe0ede9c4242aa346ca6c609b7a4d8e4e1d204d79d93ff741d58d3ca14e43a2e49cd696bd4bd54c13e62d1080320ee233963bac26f25bb0b4fada86e813ca2
diff --git a/games-emulation/dosbox/dosbox-0.74.3.ebuild b/games-emulation/dosbox/dosbox-0.74.3.ebuild
new file mode 100644
index 000000000000..167f646d3605
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.74.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic
+
+case "${PV}" in
+9999)
+ MY_P=${PN}
+ ESVN_REPO_URI="https://svn.code.sf.net/p/dosbox/code-0/dosbox/trunk"
+ inherit subversion
+ ;;
+*_pre*)
+ MY_PV=0-r${PV#*_pre}
+ MY_P=${PN}-code-${MY_PV}-${PN}-trunk
+ SRC_URI="https://sourceforge.net/code-snapshots/svn/d/do/dosbox/code-0/${MY_P}.zip"
+ BDEPEND="app-arch/unzip"
+ ;;
+*)
+ MY_PV=$(ver_rs 2 -)
+ MY_P=${PN}-${MY_PV}
+ SRC_URI="mirror://sourceforge/dosbox/${MY_P}.tar.gz"
+ ;;
+esac
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="https://www.dosbox.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="alsa +core-inline debug hardened opengl X"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/glu virtual/opengl )
+ debug? ( sys-libs/ncurses:0= )
+ X? ( x11-libs/libX11 )
+ media-libs/libpng:0=
+ media-libs/libsdl[joystick,opengl?,video,X?]
+ media-libs/sdl-net
+ media-libs/sdl-sound
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ac_cv_lib_X11_main=$(usex X yes no) \
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable core-inline) \
+ $(use_enable !hardened dynamic-core) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ default
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+}