summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-03-31 04:21:43 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-03-31 04:21:59 -0400
commit7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a (patch)
tree00dbe25ea86a97b7649f42c59ee6f938164c0367 /games-emulation/gngeo/gngeo-0.8.ebuild
parentdev-go/go-crypto: src_test: add missing die (diff)
downloadgentoo-7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a.tar.gz
gentoo-7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a.tar.bz2
gentoo-7f66870d913ad192d3ec1a8b5fc6d09e79e60d7a.zip
games-emulation/gngeo: build with gcc5 (bug #571056); respect CFLAGS
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.8.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.8.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/games-emulation/gngeo/gngeo-0.8.ebuild b/games-emulation/gngeo/gngeo-0.8.ebuild
index c6b76ced4f16..d994c7897b97 100644
--- a/games-emulation/gngeo/gngeo-0.8.ebuild
+++ b/games-emulation/gngeo/gngeo-0.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils autotools games
+inherit eutils autotools flag-o-matic games
DESCRIPTION="A NeoGeo emulator"
HOMEPAGE="https://code.google.com/p/gngeo/"
@@ -23,9 +23,11 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-execstacks.patch \
"${FILESDIR}"/${P}-zlib.patch \
- "${FILESDIR}"/${P}-concurrentMake.patch
+ "${FILESDIR}"/${P}-concurrentMake.patch \
+ "${FILESDIR}"/${P}-cflags.patch
mv configure.in configure.ac || die
eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #571056)
}
src_configure() {