summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-02 20:49:28 -0500
committerJames Le Cuirot <chewi@gentoo.org>2018-08-27 22:16:15 +0100
commitfbcf13fcb97f376f89025460808d52270cfaad6e (patch)
treede6f4731a38d56eb9b94a35e9495cdf6e36fdfd2 /games-emulation/higan
parentgames-emulation/dosbox: eutils->desktop (diff)
downloadgentoo-fbcf13fcb97f376f89025460808d52270cfaad6e.tar.gz
gentoo-fbcf13fcb97f376f89025460808d52270cfaad6e.tar.bz2
gentoo-fbcf13fcb97f376f89025460808d52270cfaad6e.zip
games-emulation/higan: eutils->desktop
Only ahs eutils for the implicit desktop inheritance for doicon and make_desktop_entry. Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'games-emulation/higan')
-rw-r--r--games-emulation/higan/higan-106_p1-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-emulation/higan/higan-106_p1-r1.ebuild b/games-emulation/higan/higan-106_p1-r1.ebuild
index a39e0db7e729..afaa222f9248 100644
--- a/games-emulation/higan/higan-106_p1-r1.ebuild
+++ b/games-emulation/higan/higan-106_p1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils gnome2-utils toolchain-funcs qmake-utils
+inherit desktop gnome2-utils toolchain-funcs qmake-utils
MY_COMMIT=41efdba45afa770db99bc7484a8ad340ccc597d2
@@ -47,6 +47,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${MY_COMMIT}-${MY_COMMIT}
+PATCHES=(
+ "${FILESDIR}"/${P}-header-locations.patch
+ "${FILESDIR}"/${P}-QA.patch
+)
+
disable_module() {
sed -i \
-e "s|$1\b||" \
@@ -54,15 +59,11 @@ disable_module() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-header-locations.patch
- epatch "${FILESDIR}"/${P}-QA.patch
-
+ default
sed -i \
-e "/handle/s#/usr/local/lib#/usr/$(get_libdir)#" \
nall/dl.hpp || die "fixing libdir failed!"
- eapply_user
-
# audio modules
use ao || disable_module audio.ao
use openal || disable_module audio.openal