summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-04 11:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-04 12:11:24 +0200
commit8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e (patch)
tree54220d57bcff4d519c8290166f79473999f425a2 /games-emulation/mupen64plus-video-rice
parentdev-haskell/conduit: amd64 stable wrt bug #550394 (diff)
downloadgentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.gz
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.bz2
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.zip
games-emulation/mupen64plus*: Version bump to 2.5
Bump mupen64plus to 2.5 which brings a number of bug fixes. Switch to SDL2 as its support become stable and the default. Also switch m64py to SDL2 to match. Package-Manager: portage-2.2.22
Diffstat (limited to 'games-emulation/mupen64plus-video-rice')
-rw-r--r--games-emulation/mupen64plus-video-rice/Manifest1
-rw-r--r--games-emulation/mupen64plus-video-rice/metadata.xml3
-rw-r--r--games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild82
3 files changed, 86 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-video-rice/Manifest b/games-emulation/mupen64plus-video-rice/Manifest
index 0ae3e56f2894..26e5de834a0f 100644
--- a/games-emulation/mupen64plus-video-rice/Manifest
+++ b/games-emulation/mupen64plus-video-rice/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-video-rice-src-2.0.tar.gz 362013 SHA256 3eb076e7c38ab45c9ec752d30e00eca022a9e0c6ead1a22df13ad94902e08238 SHA512 bbab67be20b6d2ed6a246de8a2b955051489ac128ddecff0e3fc54782fc1d17ed8f9e1cded22d215b2c5c865b4b5fe831fffb28803247a2e494746565d23d764 WHIRLPOOL ab4399e0c70351e69995a5f40aa308b4d37489b7997d8a0eae97a183c62eea6976469c1e420c04cd24f9c32e9828d677264ce684e57af2500e7e57047bf98011
+DIST mupen64plus-video-rice-src-2.5.tar.gz 339012 SHA256 969f65b9f42f48bc7e840e4ed1342233e4371c2edca5aa8f36f69c4b20955828 SHA512 d3e9c3b3097ca9b9d896498bb34374a14ec1948fce8b795e755bb13a88f3066289fe2500666b4057e719bf3f1b38b840f8a60eaeccdcdddfab69b1986c953d61 WHIRLPOOL ff5f5fa9f74dc6110239998a2a0025b2fbf796dfd98a65f80d57ccb1197c4df7904890734445e073a2b89f90793da565527b6d7ab32a62e504d10fe6aaf9d6f5
diff --git a/games-emulation/mupen64plus-video-rice/metadata.xml b/games-emulation/mupen64plus-video-rice/metadata.xml
index 9af84f31de74..31d3b719824b 100644
--- a/games-emulation/mupen64plus-video-rice/metadata.xml
+++ b/games-emulation/mupen64plus-video-rice/metadata.xml
@@ -9,6 +9,9 @@
<email>joker@gentoo.org</email>
<name>Christian Birchinger</name>
</maintainer>
+ <use>
+ <flag name="gles2">Use GLES2 instead of OpenGL</flag>
+ </use>
<upstream>
<remote-id type="github">mupen64plus/mupen64plus-video-rice</remote-id>
</upstream>
diff --git a/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild
new file mode 100644
index 000000000000..73fa3813795e
--- /dev/null
+++ b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, rice video plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2 cpu_flags_x86_sse"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2=]
+ media-libs/libpng:0=
+ media-libs/libsdl2:0=[video]
+ virtual/opengl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NO_ASM=$(usex cpu_flags_x86_sse 0 1)
+ USE_GLES=$(usex gles2 1 0)
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}