summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-19 04:16:26 +0100
committerSam James <sam@gentoo.org>2023-04-19 04:16:26 +0100
commit3fd99ef96cb5cef6dc9db82bf844076064718503 (patch)
treecb8fd80e1bc33b81ab87a3aa9892ffa73c430b62 /games-emulation/openmsx
parentgames-strategy/endless-sky: fix build w/ gcc 13 (diff)
downloadgentoo-3fd99ef96cb5cef6dc9db82bf844076064718503.tar.gz
gentoo-3fd99ef96cb5cef6dc9db82bf844076064718503.tar.bz2
gentoo-3fd99ef96cb5cef6dc9db82bf844076064718503.zip
games-emulation/openmsx: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/898908 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/files/openmsx-18.0-gcc13.patch20
-rw-r--r--games-emulation/openmsx/openmsx-18.0-r2.ebuild7
2 files changed, 25 insertions, 2 deletions
diff --git a/games-emulation/openmsx/files/openmsx-18.0-gcc13.patch b/games-emulation/openmsx/files/openmsx-18.0-gcc13.patch
new file mode 100644
index 000000000000..3da34aba3aa0
--- /dev/null
+++ b/games-emulation/openmsx/files/openmsx-18.0-gcc13.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/898908
+https://github.com/openMSX/openMSX/commit/b50d02069c09f11c687637c64ca1b459a5def28c
+
+From b50d02069c09f11c687637c64ca1b459a5def28c Mon Sep 17 00:00:00 2001
+From: m9710797 <vermaelen.wouter@gmail.com>
+Date: Sat, 4 Feb 2023 16:37:39 +0100
+Subject: [PATCH] Added missing #include
+
+Thanks to 'musuruan' for reporting.
+https://github.com/openMSX/openMSX/issues/1487
+--- a/src/utils/hash_set.hh
++++ b/src/utils/hash_set.hh
+@@ -11,6 +11,7 @@
+ #include "unreachable.hh"
+ #include "xrange.hh"
+ #include <cassert>
++#include <cstdint>
+ #include <cstdlib>
+ #include <functional>
+ #include <initializer_list>
diff --git a/games-emulation/openmsx/openmsx-18.0-r2.ebuild b/games-emulation/openmsx/openmsx-18.0-r2.ebuild
index ba32a858f88c..d2c45954266a 100644
--- a/games-emulation/openmsx/openmsx-18.0-r2.ebuild
+++ b/games-emulation/openmsx/openmsx-18.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,7 +38,10 @@ the following directories: /usr/share/${PN}/systemroms
or ~/.openMSX/share/systemroms
"
-PATCHES=( "${FILESDIR}/${P}-add-ctime.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-add-ctime.patch"
+ "${FILESDIR}/${P}-gcc13.patch"
+)
src_prepare() {
default