summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-09-06 21:03:59 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-09-06 21:05:00 -0500
commit6d6d0127c785423692e175399b4e6c317587524a (patch)
tree6df658fe34dbd576f1823c4e2c5d4b13257f7747 /games-emulation/openmsx
parentapp-arch/zstd: Stabilize 1.5.2-r1 arm64, #868990 (diff)
downloadgentoo-6d6d0127c785423692e175399b4e6c317587524a.tar.gz
gentoo-6d6d0127c785423692e175399b4e6c317587524a.tar.bz2
gentoo-6d6d0127c785423692e175399b4e6c317587524a.zip
games-emulation/openmsx: fix time_t build failure
Closes: https://bugs.gentoo.org/868726 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/files/openmsx-18.0-add-ctime.patch15
-rw-r--r--games-emulation/openmsx/openmsx-18.0-r2.ebuild (renamed from games-emulation/openmsx/openmsx-18.0-r1.ebuild)2
2 files changed, 17 insertions, 0 deletions
diff --git a/games-emulation/openmsx/files/openmsx-18.0-add-ctime.patch b/games-emulation/openmsx/files/openmsx-18.0-add-ctime.patch
new file mode 100644
index 000000000000..bc104acaeec5
--- /dev/null
+++ b/games-emulation/openmsx/files/openmsx-18.0-add-ctime.patch
@@ -0,0 +1,15 @@
+https://github.com/openMSX/openMSX/pull/1445
+https://bugs.gentoo.org/868726
+
+diff --git a/src/file/FileBase.hh b/src/file/FileBase.hh
+index ec17fb641..d7397f908 100644
+--- a/src/file/FileBase.hh
++++ b/src/file/FileBase.hh
+@@ -4,6 +4,7 @@
+ #include "MemBuffer.hh"
+ #include "span.hh"
+ #include <cstdint>
++#include <ctime>
+ #include <string>
+
+ namespace openmsx {
diff --git a/games-emulation/openmsx/openmsx-18.0-r1.ebuild b/games-emulation/openmsx/openmsx-18.0-r2.ebuild
index 74a4c7604b70..ba32a858f88c 100644
--- a/games-emulation/openmsx/openmsx-18.0-r1.ebuild
+++ b/games-emulation/openmsx/openmsx-18.0-r2.ebuild
@@ -38,6 +38,8 @@ the following directories: /usr/share/${PN}/systemroms
or ~/.openMSX/share/systemroms
"
+PATCHES=( "${FILESDIR}/${P}-add-ctime.patch" )
+
src_prepare() {
default
sed -i \