summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-05-03 13:58:21 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-05-03 13:58:37 -0400
commit9cd74b65b74cc8dade5eedb5f4cbc6a1385eb752 (patch)
treeac796432b1ca08a374ebfc9ba966619663a410ab /games-emulation/sdlmame
parentdev-qt/qtwebsockets: USE=ssl must be in sync with the same flag in qtnetwork (diff)
downloadgentoo-9cd74b65b74cc8dade5eedb5f4cbc6a1385eb752.tar.gz
gentoo-9cd74b65b74cc8dade5eedb5f4cbc6a1385eb752.tar.bz2
gentoo-9cd74b65b74cc8dade5eedb5f4cbc6a1385eb752.zip
games-emulation/sdlmame: fix compile when qt5 isn't installed (bug #581972)
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-emulation/sdlmame')
-rw-r--r--games-emulation/sdlmame/files/sdlmame-0.173-qt.patch29
-rw-r--r--games-emulation/sdlmame/sdlmame-0.173.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/sdlmame/files/sdlmame-0.173-qt.patch b/games-emulation/sdlmame/files/sdlmame-0.173-qt.patch
new file mode 100644
index 000000000000..f9c384d91cf8
--- /dev/null
+++ b/games-emulation/sdlmame/files/sdlmame-0.173-qt.patch
@@ -0,0 +1,29 @@
+No point in adding qt-related things to the compile line unless the qt debugger is wanted
+
+--- scripts/src/osd/sdl_cfg.lua.orig
++++ scripts/src/osd/sdl_cfg.lua
+@@ -115,14 +115,16 @@
+ configuration { }
+
+ elseif _OPTIONS["targetos"]=="linux" then
+- if _OPTIONS["QT_HOME"]~=nil then
+- buildoptions {
+- "-I" .. backtick(_OPTIONS["QT_HOME"] .. "/bin/qmake -query QT_INSTALL_HEADERS"),
+- }
+- else
+- buildoptions {
+- backtick("pkg-config --cflags Qt5Widgets"),
+- }
++ if _OPTIONS["USE_QTDEBUG"]=="1" then
++ if _OPTIONS["QT_HOME"]~=nil then
++ buildoptions {
++ "-I" .. backtick(_OPTIONS["QT_HOME"] .. "/bin/qmake -query QT_INSTALL_HEADERS"),
++ }
++ else
++ buildoptions {
++ backtick("pkg-config --cflags Qt5Widgets"),
++ }
++ end
+ end
+ elseif _OPTIONS["targetos"]=="macosx" then
+ defines {
diff --git a/games-emulation/sdlmame/sdlmame-0.173.ebuild b/games-emulation/sdlmame/sdlmame-0.173.ebuild
index adc1cb718175..7fa0a7cd5af8 100644
--- a/games-emulation/sdlmame/sdlmame-0.173.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.173.ebuild
@@ -73,6 +73,7 @@ src_unpack() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-qt.patch
# Disable using bundled libraries
enable_feature USE_SYSTEM_LIB_EXPAT
enable_feature USE_SYSTEM_LIB_FLAC