summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-01 02:20:05 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-01 02:20:05 -0500
commit13416e8e5b771305ceab90d018877106abcd96ed (patch)
tree3c481acc7f987b64c4accfc69afe0b6d63aa8387 /games-emulation/vbam
parentdev-php/pecl-apcu_bc: Initial commit (diff)
downloadgentoo-13416e8e5b771305ceab90d018877106abcd96ed.tar.gz
gentoo-13416e8e5b771305ceab90d018877106abcd96ed.tar.bz2
gentoo-13416e8e5b771305ceab90d018877106abcd96ed.zip
games-emulation/vbam: fix building with libsigc++-2.6 (bug #568792)
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-emulation/vbam')
-rw-r--r--games-emulation/vbam/vbam-2.0.0_pre1507.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/games-emulation/vbam/vbam-2.0.0_pre1507.ebuild b/games-emulation/vbam/vbam-2.0.0_pre1507.ebuild
index f907be223d80..f9c8f357e64b 100644
--- a/games-emulation/vbam/vbam-2.0.0_pre1507.ebuild
+++ b/games-emulation/vbam/vbam-2.0.0_pre1507.ebuild
@@ -4,7 +4,7 @@
EAPI=5
WX_GTK_VER="3.0"
-inherit cmake-utils wxwidgets gnome2-utils fdo-mime games
+inherit cmake-utils wxwidgets flag-o-matic gnome2-utils fdo-mime games
if [[ ${PV} == 9999 ]]; then
ESVN_REPO_URI="https://svn.code.sf.net/p/vbam/code/trunk"
@@ -60,6 +60,8 @@ src_prepare() {
}
src_configure() {
+ # Bug #568792
+ append-cxxflags -std=c++11 -fpermissive
local mycmakeargs=(
$(cmake-utils_use_enable cairo CAIRO)
$(cmake-utils_use_enable ffmpeg FFMPEG)