summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-15 17:32:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-15 17:33:33 -0400
commit1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2 (patch)
tree56b20dc13d945418414e70f968f07d75e1bbb207 /games-emulation
parentdev-python/humanize: Bump to 3.9.0 (diff)
downloadgentoo-1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2.tar.gz
gentoo-1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2.tar.bz2
gentoo-1ca9cc16cc005f0933cc75f7bf7a50e8f3141cd2.zip
games-emulation/mednafen: add 1.27.1
Removes support for libsndfile and adds flac in its place. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen/Manifest1
-rw-r--r--games-emulation/mednafen/mednafen-1.27.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/games-emulation/mednafen/Manifest b/games-emulation/mednafen/Manifest
index dff999e5abb8..3aabde11efd0 100644
--- a/games-emulation/mednafen/Manifest
+++ b/games-emulation/mednafen/Manifest
@@ -1 +1,2 @@
DIST mednafen-1.26.1.tar.xz 3319756 BLAKE2B d306a0754ed0c64a99cee4eacfa47f5f46ca059026bfc2ef6bfff4be82e914a2882a864538c8cb6bb948cdb9bd53651d931b033446015ad06be309893a2bfef7 SHA512 c91db3967c09a475fcd3410eb6892a99f3cf2ca2c5a78173669aa52c2e588819595d1d140e0c1888f48885327a9381c64cfb8f2074be8067984a4414c6f282bf
+DIST mednafen-1.27.1.tar.xz 3363540 BLAKE2B f74c251300af2348db00d68ef2cd998bdf4d6fb06873e03e0027d836b5b1217901b1e2cf922877b1db4c278ba4cc2674e4875a17fff52a3b8be5a447670a6385 SHA512 f55d86baa8c77fc98aae63a38235eb64f64131f180c40ed1ac7cd2ad845230348fbba05643eb5e6af203e56c39c8011b632d2bcecbd2c9f2c19b2447f6b99e83
diff --git a/games-emulation/mednafen/mednafen-1.27.1.ebuild b/games-emulation/mednafen/mednafen-1.27.1.ebuild
new file mode 100644
index 000000000000..ff0f36561a36
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-1.27.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pax-utils toolchain-funcs
+
+DESCRIPTION="Argument-driven multi-system emulator utilizing OpenGL and SDL"
+HOMEPAGE="https://mednafen.github.io/"
+SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cpu_flags_ppc_altivec flac jack"
+
+RDEPEND="
+ dev-libs/lzo:2
+ dev-libs/trio
+ media-libs/libsdl2[joystick,opengl,video]
+ media-libs/tremor
+ media-sound/musepack-tools
+ sys-libs/zlib:=[minizip]
+ virtual/libintl
+ alsa? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac )
+ jack? ( virtual/jack )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # don't let the build system mess with CFLAGS more than necessary,
+ # most are questionable (see README.PORTING/configure.ac comments)
+ # -fwrapv: kept for bug #539992
+ sed -e '/CC_OPT.*CODEGEN_FLAGS/{/-fwrapv/!d}' \
+ -e '/CC_OPT.*NO_STACK_PROTECTOR_FLAGS/d' \
+ -e '/CC_OPT.*OPTIMIZER_FLAGS/c\:' \
+ -e '/CC_OPT.*-mtune.*SS_EXTRA_FLAGS/d' \
+ -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable unnecessary warnings not to confuse users (see src/types.h)
+ append-cppflags -DMDFN_DISABLE_{NO_OPT,PICPIE}_ERRWARN
+
+ local myeconfargs=(
+ $(use_enable alsa)
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable jack)
+ $(use_with flac libflac)
+ --with-external-{lzo,mpcdec,tremor,trio}
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=(
+ ChangeLog
+ Documentation/{cheats.txt,fname_format.txt,modules.def,settings.def}
+ )
+ local HTML_DOCS=( Documentation/*.{css,html,png} )
+
+ default
+
+ pax-mark m "${ED}"/usr/bin/mednafen
+}