summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-03 16:10:52 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-03 16:10:52 +0200
commit288f883b4305bfaee177adb899a78345eb99afde (patch)
treeebb503327429408a516f519eb4bd71ee8e087cb8 /games-emulation
parentdev-lang/swi-prolog: bump 7.7 development version (diff)
downloadgentoo-288f883b4305bfaee177adb899a78345eb99afde.tar.gz
gentoo-288f883b4305bfaee177adb899a78345eb99afde.tar.bz2
gentoo-288f883b4305bfaee177adb899a78345eb99afde.zip
games-emulation/mgba: Fixed build against qt-5.11
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mgba/files/mgba-0.6.3-qt511.patch34
-rw-r--r--games-emulation/mgba/mgba-0.6.3.ebuild4
2 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/mgba/files/mgba-0.6.3-qt511.patch b/games-emulation/mgba/files/mgba-0.6.3-qt511.patch
new file mode 100644
index 000000000000..05368f6e30e7
--- /dev/null
+++ b/games-emulation/mgba/files/mgba-0.6.3-qt511.patch
@@ -0,0 +1,34 @@
+From a2b8c4ae807ae92103e14961fd34377b28cbe219 Mon Sep 17 00:00:00 2001
+From: Vicki Pfau <vi@endrift.com>
+Date: Fri, 25 May 2018 18:04:16 -0700
+Subject: [PATCH] Qt: Fix build with Qt 5.11
+
+---
+ src/platform/qt/LoadSaveState.cpp | 1 +
+ src/platform/qt/Window.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/platform/qt/LoadSaveState.cpp b/src/platform/qt/LoadSaveState.cpp
+index a381c3d22..41ddb842e 100644
+--- a/src/platform/qt/LoadSaveState.cpp
++++ b/src/platform/qt/LoadSaveState.cpp
+@@ -10,6 +10,7 @@
+ #include "GamepadButtonEvent.h"
+ #include "VFileDevice.h"
+
++#include <QAction>
+ #include <QDateTime>
+ #include <QKeyEvent>
+ #include <QPainter>
+diff --git a/src/platform/qt/Window.h b/src/platform/qt/Window.h
+index c009c7ffa..8ee63907d 100644
+--- a/src/platform/qt/Window.h
++++ b/src/platform/qt/Window.h
+@@ -6,6 +6,7 @@
+ #ifndef QGBA_WINDOW
+ #define QGBA_WINDOW
+
++#include <QAction>
+ #include <QDateTime>
+ #include <QList>
+ #include <QMainWindow>
diff --git a/games-emulation/mgba/mgba-0.6.3.ebuild b/games-emulation/mgba/mgba-0.6.3.ebuild
index 6674579a2fcc..c4859e9bec53 100644
--- a/games-emulation/mgba/mgba-0.6.3.ebuild
+++ b/games-emulation/mgba/mgba-0.6.3.ebuild
@@ -37,6 +37,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-qt511.patch"
+)
+
src_prepare() {
cmake-utils_src_prepare