summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-28 03:43:09 -0500
committerPatrice Clement <monsieurp@gentoo.org>2016-06-28 13:31:36 +0000
commit3d239d4e470c8f0c99339649ec74c4bdf86cf98f (patch)
treed088efb6d638b4b21bce9e31abfba0074285625d /games-emulation
parentapp-shells/mpv-bash-completion: verbump to 3.0 (diff)
downloadgentoo-3d239d4e470c8f0c99339649ec74c4bdf86cf98f.tar.gz
gentoo-3d239d4e470c8f0c99339649ec74c4bdf86cf98f.tar.bz2
gentoo-3d239d4e470c8f0c99339649ec74c4bdf86cf98f.zip
games-emulation/dosbox: remove games eclass and convert to EAPI 6
Gentoo-Bug: https://bugs.gentoo.org/566498 Gentoo-Bug: https://bugs.gentoo.org/587382 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1777 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox/dosbox-0.74-r2.ebuild46
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild12
2 files changed, 52 insertions, 6 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74-r2.ebuild b/games-emulation/dosbox/dosbox-0.74-r2.ebuild
new file mode 100644
index 000000000000..165707b81f2f
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.74-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0 )
+ opengl? ( virtual/glu virtual/opengl )
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,video,X]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang.patch
+ "${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-wine-drive-z.patch
+ "${FILESDIR}"/${P}-wine-filenames.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-core) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ default
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+}
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index f0caa33b0f3c..1c5c700e10af 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
-inherit autotools eutils subversion games
+inherit autotools eutils subversion
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
@@ -15,8 +15,8 @@ KEYWORDS=""
IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
- opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
+ opengl? ( virtual/glu virtual/opengl )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
@@ -30,12 +30,13 @@ src_unpack() {
}
src_prepare() {
+ default
subversion_src_prepare
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
@@ -47,5 +48,4 @@ src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
- prepgamesdirs
}