summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-07-31 07:58:30 -0700
committerJames Le Cuirot <chewi@gentoo.org>2022-07-31 21:37:22 +0100
commit4af9aade2199538e6ace3ec8d2d272cdfdb9edc6 (patch)
tree8f84a93919c881c7909c65a51c741b956b46fe18 /games-emulation
parentapp-misc/rl: drop inactive maintainer (diff)
downloadgentoo-4af9aade2199538e6ace3ec8d2d272cdfdb9edc6.tar.gz
gentoo-4af9aade2199538e6ace3ec8d2d272cdfdb9edc6.tar.bz2
gentoo-4af9aade2199538e6ace3ec8d2d272cdfdb9edc6.zip
games-emulation/pcsx2: Update live ebuild
This fixes two issues: 1. Because -DARCH_FLAGS= the build fails with the following. PCSX2 requires compiling for at least SSE 4.1 This can be fixed by replacing the cmake argument with -DDISABLE_ADVANCE_SIMD=ON. 2. Upstream removed crcs for a few unofficial games that are required to fix major playability issues. These versions of the games can be far preferable to the official versions where one was completely broken in the North American release, but fixed in a fan patched version. Upstream-PR: https://github.com/PCSX2/pcsx2/pull/5082 Upstream-Issue: https://github.com/PCSX2/pcsx2/issues/1762 Upstream-Issue: https://github.com/PCSX2/pcsx2/issues/5062 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/26685 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.0-crcs.patch43
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild6
2 files changed, 48 insertions, 1 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.0-crcs.patch b/games-emulation/pcsx2/files/pcsx2-1.7.0-crcs.patch
new file mode 100644
index 000000000000..aa647cd09c07
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.0-crcs.patch
@@ -0,0 +1,43 @@
+Upstream-PR: https://github.com/PCSX2/pcsx2/pull/5082
+Upstream-Issue: https://github.com/PCSX2/pcsx2/issues/1762
+Upstream-Issue: https://github.com/PCSX2/pcsx2/issues/5062
+
+From: orbea <orbea@riseup.net>
+Date: Sun, 28 Nov 2021 16:18:48 -0800
+Subject: [PATCH] Revert "GS: Remove Unofficial CRCs (#4082)"
+
+These games hacks are still used and can be removed
+again when a better solution is available.
+
+This reverts commit 6bcdb55f22d468b2eb8b95fd35bd071f9272a89c.
+
+--- a/pcsx2/GS/GSCrc.cpp
++++ b/pcsx2/GS/GSCrc.cpp
+@@ -22,6 +22,8 @@ const CRC::Game CRC::m_games[] =
+ {
+ // Note: IDs 0x7ACF7E03, 0x7D4EA48F, 0x37C53760 - shouldn't be added as it's from the multiloaders when packing games.
+ {0x00000000, NoTitle, NoRegion, 0},
++ {0xF46142D3, ArTonelico2, NoRegion, 0},
++ {0xC38067F4, ArTonelico2, NoRegion, 0}, // project metafalica 1.0
+ {0xF95F37EE, ArTonelico2, US, 0},
+ {0x68CE6801, ArTonelico2, JP, 0},
+ {0xCE2C1DBF, ArTonelico2, EU, 0},
+@@ -164,6 +166,8 @@ const CRC::Game CRC::m_games[] =
+ {0xBF6F101F, GiTS, EU, 0}, // same CRC as another US disc
+ {0xA616A6C2, TalesOfAbyss, US, 0},
+ {0x14FE77F7, TalesOfAbyss, US, 0},
++ {0x045D77E9, TalesOfAbyss, JPUNDUB, 0},
++ {0x14FD77F7, TalesOfAbyss, JPUNDUB, 0},
+ {0xAA5EC3A3, TalesOfAbyss, JP, 0},
+ {0xFB236A46, SonicUnleashed, US, 0},
+ {0x8C913264, SonicUnleashed, EU, 0},
+--- a/pcsx2/GS/GSCrc.h
++++ b/pcsx2/GS/GSCrc.h
+@@ -91,6 +91,7 @@ public:
+ US,
+ EU,
+ JP,
++ JPUNDUB,
+ RU,
+ FR,
+ DE,
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 14345f880fa8..3885455b5d81 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -61,6 +61,10 @@ FILECAPS=(
-m 755 "CAP_NET_RAW+eip CAP_NET_ADMIN+eip" usr/bin/pcsx2
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-crcs.patch
+)
+
pkg_setup() {
if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
# -mxsave flag is needed when GCC >= 8.2 is used
@@ -93,8 +97,8 @@ src_configure() {
# if it something other than "Devel|Debug|Release"
local CMAKE_BUILD_TYPE="Release"
local mycmakeargs=(
- -DARCH_FLAG=
-DBUILD_SHARED_LIBS=FALSE
+ -DDISABLE_ADVANCE_SIMD=TRUE
-DDISABLE_BUILD_DATE=TRUE
-DDISABLE_PCSX2_WRAPPER=TRUE
-DDISABLE_SETCAP=TRUE