summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:06:53 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:06:53 +0200
commit65f231d3f8e95477c26ffeab12e5f748b35df26d (patch)
tree21558854e896dfc421f8ccc73e7070209d3637eb /games-emulation
parentmedia-plugins/vdr-xineliboutput: respect ${PKG_CONFIG} (diff)
downloadgentoo-65f231d3f8e95477c26ffeab12e5f748b35df26d.tar.gz
gentoo-65f231d3f8e95477c26ffeab12e5f748b35df26d.tar.bz2
gentoo-65f231d3f8e95477c26ffeab12e5f748b35df26d.zip
games-emulation/zsnes: respect ${PKG_CONFIG}
Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r9.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/games-emulation/zsnes/zsnes-1.51-r9.ebuild b/games-emulation/zsnes/zsnes-1.51-r9.ebuild
index a92368d1bf9f..f97e76f12285 100644
--- a/games-emulation/zsnes/zsnes-1.51-r9.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r9.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/nasm
- debug? ( virtual/pkgconfig )
+ virtual/pkgconfig
"
PATCHES=(
@@ -74,8 +74,8 @@ src_prepare() {
-e '/^CFLAGS=.*local/s:-pipe.*:-Wall -I.":' \
-e '/^LDFLAGS=.*local/d' \
-e '/\w*CFLAGS=.*fomit/s:-O3.*$STRIP::' \
- -e '/lncurses/s:-lncurses:`pkg-config ncurses --libs`:' \
- -e '/lcurses/s:-lcurses:`pkg-config ncurses --libs`:' \
+ -e '/lncurses/s:-lncurses:`${PKG_CONFIG} ncurses --libs`:' \
+ -e '/lcurses/s:-lcurses:`${PKG_CONFIG} ncurses --libs`:' \
configure.in || die
sed -i \
-e 's/configure.in/configure.ac/' \
@@ -85,13 +85,16 @@ src_prepare() {
}
src_configure() {
- tc-export CC
+ tc-export CC PKG_CONFIG
+
export BUILD_CXX=$(tc-getBUILD_CXX)
export NFLAGS=-O1
+
use amd64 && multilib_toolchain_setup x86
use custom-cflags || strip-flags
- append-cppflags -U_FORTIFY_SOURCE #257963
+ # bug #257963
+ append-cppflags -U_FORTIFY_SOURCE
econf \
$(use_enable ao libao) \