summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-03 22:30:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-04 00:16:17 -0400
commit82e4e1a2308eafa6f3cf048d131d63173ad9eaa2 (patch)
treeb451fce5b46f66fe998503d031a54fd4cfe08086 /games-emulation
parentprofiles/arch/amd64/no-multilib: mask games-emulation/gens (diff)
downloadgentoo-82e4e1a2308eafa6f3cf048d131d63173ad9eaa2.tar.gz
gentoo-82e4e1a2308eafa6f3cf048d131d63173ad9eaa2.tar.bz2
gentoo-82e4e1a2308eafa6f3cf048d131d63173ad9eaa2.zip
games-emulation/gens: refactor multilib usage, EAPI 7->8
There is little sense in having a REQUIRED_USE (via MULTILIB_COMPAT) and MULTILIB_USEDEP for a single choice. This hidden that this can't be built on amd64 no-multilib by trading NonSolvableDeps error with RequiredUseDefaults warning (now masked). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gens/gens-2.15.5-r2.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/games-emulation/gens/gens-2.15.5-r2.ebuild b/games-emulation/gens/gens-2.15.5-r2.ebuild
index 7b8c385e9b04..b4c3edece97b 100644
--- a/games-emulation/gens/gens-2.15.5-r2.ebuild
+++ b/games-emulation/gens/gens-2.15.5-r2.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-MULTILIB_COMPAT=( abi_x86_32 )
+inherit desktop flag-o-matic multilib
-inherit desktop flag-o-matic multilib-build
-
-DESCRIPTION="A Sega Genesis/CD/32X emulator"
+DESCRIPTION="Sega Genesis/CD/32X emulator"
HOMEPAGE="https://sourceforge.net/projects/gens/"
SRC_URI="mirror://sourceforge/gens/${P}.tar.gz"
@@ -16,12 +14,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- media-libs/libsdl[${MULTILIB_USEDEP},joystick,video]
- sys-libs/zlib[${MULTILIB_USEDEP}]
- virtual/opengl[${MULTILIB_USEDEP}]
- x11-libs/gtk+:2[${MULTILIB_USEDEP}]"
+ media-libs/libsdl[abi_x86_32(-),joystick,video]
+ sys-libs/zlib:=[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/gtk+:2[abi_x86_32(-)]"
DEPEND="${RDEPEND}"
-BDEPEND=">=dev-lang/nasm-0.98"
+BDEPEND="dev-lang/nasm"
PATCHES=(
"${FILESDIR}"/${P}-romsdir.patch
@@ -43,8 +41,9 @@ src_configure() {
src_install() {
default
+
dodoc gens.txt history.txt
newicon pixmaps/gens_small.png gens.png
- make_desktop_entry "gens" "Gens"
+ make_desktop_entry gens Gens
}