summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-06-05 22:47:48 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-06-05 22:52:40 -0500
commit8f716335882b72adc99f5df1b40b57d9723b26e7 (patch)
treeb4995606e11a112e372cc786ad0091d833a5a146 /games-emulation
parentsys-apps/bolt: 0.9.1 bump (diff)
downloadgentoo-8f716335882b72adc99f5df1b40b57d9723b26e7.tar.gz
gentoo-8f716335882b72adc99f5df1b40b57d9723b26e7.tar.bz2
gentoo-8f716335882b72adc99f5df1b40b57d9723b26e7.zip
games-emulation/openmsx: add 17.0
Drops patch which has been included in 17.0. Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/openmsx/Manifest1
-rw-r--r--games-emulation/openmsx/openmsx-17.0.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index fd28218cd55d..b6e630605161 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1 +1,2 @@
DIST openmsx-16.0.tar.gz 3997584 BLAKE2B 040bb3f6ff0338740b5212aae21db2c97fcee0e8c8ada1bc84a59d94b1b72180c4b2d5eff8cc4ae84dd95bc77f121e15c2f818f1f2e05ba7dc4781b63770db38 SHA512 a06ec56a8a768356b628e59e587ec85898643b04379da5c72bbbd8e48a0533da34a451b7e4d2a2f540f14e6bbcf833534a1bdac9014ce0c35dfd4ca179618f48
+DIST openmsx-17.0.tar.gz 4045461 BLAKE2B 46c70ce3f853aecebf8bdeddc5786903634d88d013497383490d79b0dbf455f48a70b3658b9913db197cf7e66cbc6f4da37da58b1b24d77c75b731e842c663df SHA512 4fc87efd2bfbcd12bebb4e005b18b1cb2048f5d8f3188ef9b55f1e003c8d021fb47bd67d647137daa6a8640b5656b0db363f3b62158d690ddb5f7bf1af3459e1
diff --git a/games-emulation/openmsx/openmsx-17.0.ebuild b/games-emulation/openmsx/openmsx-17.0.ebuild
new file mode 100644
index 000000000000..e64f1d8a6d6c
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-17.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit desktop flag-o-matic python-any-r1 readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="https://openmsx.org/"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+joystick"
+
+RDEPEND="dev-lang/tcl:0=
+ media-libs/alsa-lib
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick=,sound,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/sdl2-ttf
+ >=media-libs/glew-1.3.2:0=
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOC_CONTENTS="
+If you want to if you want to emulate real MSX systems and not
+only the free C-BIOS machines, put the system ROMs in one of
+the following directories: /usr/share/${PN}/systemroms
+or ~/.openMSX/share/systemroms
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^LDFLAGS:=/d' \
+ -e '/LINK_FLAGS_PREFIX/d' \
+ -e '/LINK_FLAGS+=/s/-s//' \
+ -e '/LINK_FLAGS+=\$(TARGET_FLAGS)/s/$/ $(LDFLAGS)/' \
+ build/main.mk \
+ || die
+ sed -i -e '/SYMLINK/s:true:false:' build/custom.mk || die
+ sed -i -e 's/GPL.txt//' doc/node.mk || die
+
+ # Build system only configured to use bundled version - but not from the
+ # directory it's distributed in
+ cp "${S}/Contrib/catch2/catch.hpp" "${S}/src/unittest" || die
+}
+
+src_configure() {
+ tc-export CXX
+
+ # Doesn't compile without this, and build system doesn't consistently add
+ # it properly for all compilers
+ append-cxxflags '-std=c++17'
+
+ default
+}
+
+src_compile() {
+ emake \
+ CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_SHARE_DIR="${EPREFIX}/usr/share/${PN}" \
+ V=1
+}
+
+src_test() {
+ # To get tests, we need to build with OPENMSX_FLAVOUR=unittest and then the
+ # build is stored in a directory of the pattern
+ # ${WORKDIR}/derived/*-unittest/. This is separate from the actual build,
+ # stored in ${WORKDIR}/derived/*-opt. The unittest binary and the workdir
+ # binary are in each of these directories under their `bin` directories.
+ emake \
+ V=1 \
+ CXXFLAGS="${CXXFLAGS}" \
+ OPENMSX_FLAVOUR=unittest
+
+ # There will only ever be one *-unittest directory
+ "${S}"/derived/*-unittest/bin/openmsx || die
+}
+
+src_install() {
+ # To guarantee installing the proper binary in case tests were built,
+ # specify the default OPENMSX_FLAVOUR
+ emake \
+ V=1 \
+ INSTALL_BINARY_DIR="${ED}/usr/bin" \
+ INSTALL_SHARE_DIR="${ED}/usr/share/${PN}" \
+ INSTALL_DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ OPENMSX_FLAVOUR=opt \
+ install
+
+ einstalldocs
+ readme.gentoo_create_doc
+
+ for i in 16 32 48 64 128 256 ; do
+ newicon -s "${i}" "share/icons/openMSX-logo-${i}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "openMSX"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_pkg_postinst
+}