summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-17 21:24:21 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-03-17 21:27:37 +0000
commitf58b89416f23124b498a887940095744da27a8a2 (patch)
tree0624e1079e9128e713c72d78feb06f2c80e40da8 /games-engines/openxcom
parentgames-engines/openxcom: Fix 9999 icons and desktop file installation (diff)
downloadgentoo-f58b89416f23124b498a887940095744da27a8a2.tar.gz
gentoo-f58b89416f23124b498a887940095744da27a8a2.tar.bz2
gentoo-f58b89416f23124b498a887940095744da27a8a2.zip
games-engines/openxcom: Add 20180317 snapshot as releases are ancient
This is not tested beyond building. It's this or we drop the releases altogether as 1.0.0 no longer builds. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'games-engines/openxcom')
-rw-r--r--games-engines/openxcom/Manifest1
-rw-r--r--games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/games-engines/openxcom/Manifest b/games-engines/openxcom/Manifest
index 5b89b86ae4cb..dcb76731ffcf 100644
--- a/games-engines/openxcom/Manifest
+++ b/games-engines/openxcom/Manifest
@@ -1 +1,2 @@
DIST openxcom-1.0.0.tar.gz 2068640 BLAKE2B ce1c35d3d25e5f327549b3656f4b41d6e37503619c7ccb13ee5382faba905f491c01a0e2af03b70b7237bea3f3fd4a51f7a2be2c44c1feade1b848ad1a414fa3 SHA512 597abd2e7160551a3d6020d7c6fec863f86b708910ee582d446f2a5f97be94dc7e2522ede2e7ab4f62a2d21acf07ce441a435f74b530950e2f0b5791c00e06ab
+DIST openxcom-1.0.0_p20180317.tar.gz 2801430 BLAKE2B 8a3718fc99f733c145034509b596de8dd17a8bdfe1aa05b68571c66245eea45f997488e57a2811f604e0aac702e30614fcd55ecc71858f49b357afb9e8fc5de4 SHA512 57ff9a9cbbbf48b8c4f792458edf0590d7d0df9a5805eab13a4c984713311e98587afca00778e82bd66fb2f330b354ca80703b87922a92f9ae48e5bdecf68442
diff --git a/games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild b/games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild
new file mode 100644
index 000000000000..2b0cd1f377b6
--- /dev/null
+++ b/games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils gnome2-utils
+
+COMMIT="ea9ac466221f8b4f8974d2db1c42dc4ad6126564"
+DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
+HOMEPAGE="http://openxcom.org/"
+SRC_URI="https://github.com/SupSuper/OpenXcom/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
+ media-libs/libsdl[opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[flac,mikmod,vorbis]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/OpenXcom-${COMMIT}"
+DOCS=( README.md )
+
+src_compile() {
+ use doc && cmake-utils_src_compile doxygen
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ echo
+ elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
+ elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
+ elog "/usr/share/${PN}/UFO"
+ echo
+ elog "If you want to play the TFTD mod, you need to copy ANIMS, FLOP_INT,"
+ elog "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UNITS folders"
+ elog "from the original Terror from the Deep game to"
+ elog "/usr/share/${PN}/TFTD"
+ echo
+ elog "If you need or want text in some language other than english, download:"
+ elog "http://openxcom.org/translations/latest.zip and uncompress it in"
+ elog "/usr/share/${PN}/common/Language"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}