summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-15 00:27:16 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-15 00:27:31 +0200
commita8a6e1f4b7ea0ba2eb265c0cccf9e049792146cf (patch)
treee9621691594a42a5ef1a1fbd08138cc84fecf27c /games-engines/renpy/files
parentnet-analyzer/wireshark: amd64 stable wrt bug #557522 (diff)
downloadgentoo-a8a6e1f4b7ea0ba2eb265c0cccf9e049792146cf.tar.gz
gentoo-a8a6e1f4b7ea0ba2eb265c0cccf9e049792146cf.tar.bz2
gentoo-a8a6e1f4b7ea0ba2eb265c0cccf9e049792146cf.zip
games-engines/renpy: rm old 6.14 and 6.18.2
Diffstat (limited to 'games-engines/renpy/files')
-rw-r--r--games-engines/renpy/files/renpy-6.14.1-av_close_input_stream.patch11
-rw-r--r--games-engines/renpy/files/renpy-6.14.1-freetype.patch17
-rw-r--r--games-engines/renpy/files/renpy-6.14.1-multiple-abi.patch230
-rw-r--r--games-engines/renpy/files/renpy-6.14.1-remove-AVFormatParameters.patch19
-rw-r--r--games-engines/renpy/files/renpy-6.18.2-multiple-abi.patch271
5 files changed, 0 insertions, 548 deletions
diff --git a/games-engines/renpy/files/renpy-6.14.1-av_close_input_stream.patch b/games-engines/renpy/files/renpy-6.14.1-av_close_input_stream.patch
deleted file mode 100644
index c2415a2233a9..000000000000
--- a/games-engines/renpy/files/renpy-6.14.1-av_close_input_stream.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- module/ffdecode.c
-+++ module/ffdecode.c
-@@ -1356,7 +1356,7 @@
- if (is->video_stream >= 0)
- stream_component_close(is, is->video_stream);
- if (is->ic) {
-- av_close_input_stream(is->ic);
-+ av_close_input_file(is->ic);
- is->ic = NULL;
- }
-
diff --git a/games-engines/renpy/files/renpy-6.14.1-freetype.patch b/games-engines/renpy/files/renpy-6.14.1-freetype.patch
deleted file mode 100644
index a818912b8c2b..000000000000
--- a/games-engines/renpy/files/renpy-6.14.1-freetype.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Mon Apr 28 22:31:52 UTC 2014
-Subject: fix build
-
---- renpy-6.14.1-source/module/setup.py
-+++ renpy-6.14.1-source/module/setup.py
-@@ -24,8 +24,8 @@
- include("zlib.h")
- include("png.h")
- include("SDL.h", directory="SDL")
--include("ft2build.h")
--include("freetype/freetype.h", directory="freetype2")
-+include("ft2build.h") or include("ft2build.h", directory="freetype2")
-+include("freetype/freetype.h", directory="freetype2") or include("freetype.h", directory="freetype2")
- include("libavutil/avstring.h")
- include("libavformat/avformat.h")
- include("libavcodec/avcodec.h")
diff --git a/games-engines/renpy/files/renpy-6.14.1-multiple-abi.patch b/games-engines/renpy/files/renpy-6.14.1-multiple-abi.patch
deleted file mode 100644
index e200746d153a..000000000000
--- a/games-engines/renpy/files/renpy-6.14.1-multiple-abi.patch
+++ /dev/null
@@ -1,230 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Mon Feb 25 21:35:31 UTC 2013
-Subject: fix multiple abi support
-
---- /dev/null
-+++ renpy-6.14.1-source/renpy/common.py
-@@ -0,0 +1,83 @@
-+# Copyright 2004-2012 Tom Rothamel <pytom@bishoujo.us>
-+#
-+# Permission is hereby granted, free of charge, to any person
-+# obtaining a copy of this software and associated documentation files
-+# (the "Software"), to deal in the Software without restriction,
-+# including without limitation the rights to use, copy, modify, merge,
-+# publish, distribute, sublicense, and/or sell copies of the Software,
-+# and to permit persons to whom the Software is furnished to do so,
-+# subject to the following conditions:
-+#
-+# The above copyright notice and this permission notice shall be
-+# included in all copies or substantial portions of the Software.
-+#
-+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-+# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-+# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-+# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-+
-+import os
-+import sys
-+import warnings
-+from distutils.sysconfig import get_python_lib
-+
-+# Functions to be customized by distributors. ################################
-+
-+# Given the Ren'Py base directory (usually the directory containing
-+# this file), this is expected to return the path to the common directory.
-+def path_to_common(renpy_base):
-+ return renpy_base + "/common"
-+
-+# Given a directory holding a Ren'Py game, this is expected to return
-+# the path to a directory that will hold save files.
-+def path_to_saves(gamedir):
-+ import renpy #@UnresolvedImport
-+
-+ if not renpy.config.save_directory:
-+ return gamedir + "/saves"
-+
-+ # Search the path above Ren'Py for a directory named "Ren'Py Data".
-+ # If it exists, then use that for our save directory.
-+ path = renpy.config.renpy_base
-+
-+ while True:
-+ if os.path.isdir(path + "/Ren'Py Data"):
-+ return path + "/Ren'Py Data/" + renpy.config.save_directory
-+
-+ newpath = os.path.dirname(path)
-+ if path == newpath:
-+ break
-+ path = newpath
-+
-+ # Otherwise, put the saves in a platform-specific location.
-+ if renpy.android:
-+ return gamedir + "/saves"
-+
-+ elif renpy.macintosh:
-+ rv = "~/Library/RenPy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+ elif renpy.windows:
-+ if 'APPDATA' in os.environ:
-+ return os.environ['APPDATA'] + "/RenPy/" + renpy.config.save_directory
-+ else:
-+ rv = "~/RenPy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+ else:
-+ rv = "~/.renpy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+
-+# Returns the path to the Ren'Py base directory (containing common and
-+# the launcher, usually.)
-+def path_to_renpy_base():
-+ renpy_base = os.path.dirname(sys.argv[0])
-+ renpy_base = get_python_lib() + "/renpy@SLOT@"
-+ renpy_base = os.environ.get('RENPY_BASE', renpy_base)
-+ renpy_base = os.path.abspath(renpy_base)
-+
-+ return renpy_base
---- renpy-6.14.1-source/renpy.py
-+++ renpy-6.14.1-source/renpy.py
-@@ -24,65 +24,9 @@
- import os
- import sys
- import warnings
--
--# Functions to be customized by distributors. ################################
--
--# Given the Ren'Py base directory (usually the directory containing
--# this file), this is expected to return the path to the common directory.
--def path_to_common(renpy_base):
-- return renpy_base + "/common"
--
--# Given a directory holding a Ren'Py game, this is expected to return
--# the path to a directory that will hold save files.
--def path_to_saves(gamedir):
-- import renpy #@UnresolvedImport
--
-- if not renpy.config.save_directory:
-- return gamedir + "/saves"
--
-- # Search the path above Ren'Py for a directory named "Ren'Py Data".
-- # If it exists, then use that for our save directory.
-- path = renpy.config.renpy_base
--
-- while True:
-- if os.path.isdir(path + "/Ren'Py Data"):
-- return path + "/Ren'Py Data/" + renpy.config.save_directory
--
-- newpath = os.path.dirname(path)
-- if path == newpath:
-- break
-- path = newpath
--
-- # Otherwise, put the saves in a platform-specific location.
-- if renpy.android:
-- return gamedir + "/saves"
--
-- elif renpy.macintosh:
-- rv = "~/Library/RenPy/" + renpy.config.save_directory
-- return os.path.expanduser(rv)
--
-- elif renpy.windows:
-- if 'APPDATA' in os.environ:
-- return os.environ['APPDATA'] + "/RenPy/" + renpy.config.save_directory
-- else:
-- rv = "~/RenPy/" + renpy.config.save_directory
-- return os.path.expanduser(rv)
--
-- else:
-- rv = "~/.renpy/" + renpy.config.save_directory
-- return os.path.expanduser(rv)
--
--
--# Returns the path to the Ren'Py base directory (containing common and
--# the launcher, usually.)
--def path_to_renpy_base():
-- renpy_base = os.path.dirname(sys.argv[0])
-- renpy_base = os.environ.get('RENPY_BASE', renpy_base)
-- renpy_base = os.path.abspath(renpy_base)
--
-- return renpy_base
--
--##############################################################################
-+from distutils.sysconfig import get_python_lib
-+sys.path.append(get_python_lib() + "/renpy@SLOT@")
-+import renpy.common as common
-
- # The version of the Mac Launcher and py4renpy that we require.
- macos_version = (6, 14, 0)
-@@ -97,21 +41,9 @@
- print "Ren'Py requires at least python 2.6."
- sys.exit(0)
-
--android = ("ANDROID_PRIVATE" in os.environ)
--
--# Android requires us to add code to the main module, and to command some
--# renderers.
--if android:
-- __main__ = sys.modules["__main__"]
-- __main__.path_to_renpy_base = path_to_renpy_base
-- __main__.path_to_common = path_to_common
-- __main__.path_to_saves = path_to_saves
-- os.environ["RENPY_RENDERER"] = "gl"
-- os.environ["RENPY_GL_ENVIRON"] = "limited"
--
- def main():
-
-- renpy_base = path_to_renpy_base()
-+ renpy_base = common.path_to_renpy_base()
-
- # Add paths.
- if os.path.exists(renpy_base + "/module"):
-@@ -133,14 +65,9 @@
- print >>sys.stderr, "Could not import renpy.bootstrap. Please ensure you decompressed Ren'Py"
- print >>sys.stderr, "correctly, preserving the directory structure."
- raise
--
-- if android:
-- renpy.linux = False
-- renpy.android = True
-
- renpy.bootstrap.bootstrap(renpy_base)
-
--if __name__ == "__main__":
-- main()
-
--
-+if __name__ == "__main__":
-+ main()
---- renpy-6.14.1-source/renpy/main.py
-+++ renpy-6.14.1-source/renpy/main.py
-@@ -27,7 +27,7 @@
- import zipfile
- import subprocess
- from cPickle import loads, dumps
--import __main__
-+import renpy.common as common
-
-
- def save_persistent():
-@@ -172,7 +172,7 @@
- renpy.config.searchpath = [ renpy.config.gamedir ]
-
- # Find the common directory.
-- commondir = __main__.path_to_common(renpy.config.renpy_base) # E1101 @UndefinedVariable
-+ commondir = common.path_to_common(renpy.config.renpy_base) # E1101 @UndefinedVariable
-
- if os.path.isdir(commondir):
- renpy.config.searchpath.append(commondir)
-@@ -227,7 +227,7 @@
-
- # Find the save directory.
- if renpy.config.savedir is None:
-- renpy.config.savedir = __main__.path_to_saves(renpy.config.gamedir) # E1101 @UndefinedVariable
-+ renpy.config.savedir = common.path_to_saves(renpy.config.gamedir) # E1101 @UndefinedVariable
-
- if renpy.game.args.savedir: #@UndefinedVariable
- renpy.config.savedir = renpy.game.args.savedir #@UndefinedVariable
diff --git a/games-engines/renpy/files/renpy-6.14.1-remove-AVFormatParameters.patch b/games-engines/renpy/files/renpy-6.14.1-remove-AVFormatParameters.patch
deleted file mode 100644
index e66106c91fcd..000000000000
--- a/games-engines/renpy/files/renpy-6.14.1-remove-AVFormatParameters.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- module/ffdecode.c
-+++ module/ffdecode.c
-@@ -1152,7 +1152,6 @@
- AVFormatContext *ic;
- int err, i, ret, video_index, audio_index;
- AVPacket pkt1, *pkt = &pkt1;
-- AVFormatParameters params, *ap = &params;
- int codecs_locked = 0;
-
- // url_set_interrupt_cb(decode_interrupt_cb);
-@@ -1162,8 +1161,6 @@
- is->video_stream = -1;
- is->audio_stream = -1;
-
-- memset(ap, 0, sizeof(*ap));
--
- is->io_context = rwops_open(is->rwops);
-
- codecs_locked = 1;
diff --git a/games-engines/renpy/files/renpy-6.18.2-multiple-abi.patch b/games-engines/renpy/files/renpy-6.18.2-multiple-abi.patch
deleted file mode 100644
index a569fa4e62d2..000000000000
--- a/games-engines/renpy/files/renpy-6.18.2-multiple-abi.patch
+++ /dev/null
@@ -1,271 +0,0 @@
-Author: hasufell <hasufell@gentoo.org>
-Date: Tue Jan 21 01:02:00 2014 +0100
-
- fix multiple abi support
-
---- renpy.py
-+++ renpy.py
-@@ -29,92 +29,9 @@
- import sys
- import warnings
-
--# Functions to be customized by distributors. ################################
--
--# Given the Ren'Py base directory (usually the directory containing
--# this file), this is expected to return the path to the common directory.
--def path_to_common(renpy_base):
-- return renpy_base + "/renpy/common"
--
--# Given a directory holding a Ren'Py game, this is expected to return
--# the path to a directory that will hold save files.
--def path_to_saves(gamedir):
-- import renpy #@UnresolvedImport
--
-- # Makes sure the permissions are right on the save directory.
-- def test_writable(d):
-- try:
-- fn = os.path.join(d, "test.txt")
-- open(fn, "w").close()
-- open(fn, "r").close()
-- os.unlink(fn)
-- return True
-- except:
-- return False
--
--
-- # Android.
-- if renpy.android:
-- paths = [
-- os.path.join(os.environ["ANDROID_OLD_PUBLIC"], "game/saves"),
-- os.path.join(os.environ["ANDROID_PRIVATE"], "saves"),
-- os.path.join(os.environ["ANDROID_PUBLIC"], "saves"),
-- ]
--
-- for rv in paths:
-- if os.path.isdir(rv) and test_writable(rv):
-- break
--
-- print "Using savedir", rv
--
-- # We return the last path as the default.
--
-- return rv
--
--
-- # No save directory given.
-- if not renpy.config.save_directory:
-- return gamedir + "/saves"
--
-- # Search the path above Ren'Py for a directory named "Ren'Py Data".
-- # If it exists, then use that for our save directory.
-- path = renpy.config.renpy_base
--
-- while True:
-- if os.path.isdir(path + "/Ren'Py Data"):
-- return path + "/Ren'Py Data/" + renpy.config.save_directory
--
-- newpath = os.path.dirname(path)
-- if path == newpath:
-- break
-- path = newpath
--
-- # Otherwise, put the saves in a platform-specific location.
-- if renpy.macintosh:
-- rv = "~/Library/RenPy/" + renpy.config.save_directory
-- return os.path.expanduser(rv)
--
-- elif renpy.windows:
-- if 'APPDATA' in os.environ:
-- return os.environ['APPDATA'] + "/RenPy/" + renpy.config.save_directory
-- else:
-- rv = "~/RenPy/" + renpy.config.save_directory
-- return os.path.expanduser(rv)
--
-- else:
-- rv = "~/.renpy/" + renpy.config.save_directory
-- return os.path.expanduser(rv)
--
--
--# Returns the path to the Ren'Py base directory (containing common and
--# the launcher, usually.)
--def path_to_renpy_base():
-- renpy_base = os.path.dirname(os.path.realpath(sys.argv[0]))
-- renpy_base = os.path.abspath(renpy_base)
--
-- return renpy_base
--
--##############################################################################
-+from distutils.sysconfig import get_python_lib
-+sys.path.append(get_python_lib() + "/renpy@SLOT@")
-+import renpy.common as common
-
- # The version of the Mac Launcher and py4renpy that we require.
- macos_version = (6, 14, 0)
-@@ -142,7 +59,7 @@
-
- def main():
-
-- renpy_base = path_to_renpy_base()
-+ renpy_base = common.path_to_renpy_base()
-
- # Add paths.
- if os.path.exists(renpy_base + "/module"):
---- /dev/null
-+++ renpy/common.py
-@@ -0,0 +1,127 @@
-+# This file is part of Ren'Py. The license below applies to Ren'Py only.
-+# Games and other projects that use Ren'Py may use a different license.
-+
-+# Copyright 2004-2014 Tom Rothamel <pytom@bishoujo.us>
-+#
-+# Permission is hereby granted, free of charge, to any person
-+# obtaining a copy of this software and associated documentation files
-+# (the "Software"), to deal in the Software without restriction,
-+# including without limitation the rights to use, copy, modify, merge,
-+# publish, distribute, sublicense, and/or sell copies of the Software,
-+# and to permit persons to whom the Software is furnished to do so,
-+# subject to the following conditions:
-+#
-+# The above copyright notice and this permission notice shall be
-+# included in all copies or substantial portions of the Software.
-+#
-+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-+# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-+# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-+# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-+
-+import os
-+import sys
-+import warnings
-+from distutils.sysconfig import get_python_lib
-+
-+# Functions to be customized by distributors. ################################
-+
-+# Given the Ren'Py base directory (usually the directory containing
-+# this file), this is expected to return the path to the common directory.
-+def path_to_common(renpy_base):
-+ return renpy_base + "/renpy/common"
-+
-+# Given a directory holding a Ren'Py game, this is expected to return
-+# the path to a directory that will hold save files.
-+def path_to_saves(gamedir):
-+ import renpy #@UnresolvedImport
-+
-+ # Makes sure the permissions are right on the save directory.
-+ def test_writable(d):
-+ try:
-+ fn = os.path.join(d, "test.txt")
-+ open(fn, "w").close()
-+ open(fn, "r").close()
-+ os.unlink(fn)
-+ return True
-+ except:
-+ return False
-+
-+
-+ # Makes sure the permissions are right on the save directory.
-+ def test_writable(d):
-+ try:
-+ fn = os.path.join(d, "test.txt")
-+ open(fn, "w").close()
-+ open(fn, "r").close()
-+ os.unlink(fn)
-+ return True
-+ except:
-+ return False
-+
-+
-+
-+ # Android.
-+ if renpy.android:
-+ paths = [
-+ os.path.join(os.environ["ANDROID_OLD_PUBLIC"], "game/saves"),
-+ os.path.join(os.environ["ANDROID_PRIVATE"], "saves"),
-+ os.path.join(os.environ["ANDROID_PUBLIC"], "saves"),
-+ ]
-+
-+ for rv in paths:
-+ if os.path.isdir(rv) and test_writable(rv):
-+ break
-+
-+ print "Using savedir", rv
-+
-+ # We return the last path as the default.
-+
-+ return rv
-+
-+
-+ # No save directory given.
-+ if not renpy.config.save_directory:
-+ return gamedir + "/saves"
-+
-+ # Search the path above Ren'Py for a directory named "Ren'Py Data".
-+ # If it exists, then use that for our save directory.
-+ path = renpy.config.renpy_base
-+
-+ while True:
-+ if os.path.isdir(path + "/Ren'Py Data"):
-+ return path + "/Ren'Py Data/" + renpy.config.save_directory
-+
-+ newpath = os.path.dirname(path)
-+ if path == newpath:
-+ break
-+ path = newpath
-+
-+ # Otherwise, put the saves in a platform-specific location.
-+ if renpy.macintosh:
-+ rv = "~/Library/RenPy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+ elif renpy.windows:
-+ if 'APPDATA' in os.environ:
-+ return os.environ['APPDATA'] + "/RenPy/" + renpy.config.save_directory
-+ else:
-+ rv = "~/RenPy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+ else:
-+ rv = "~/.renpy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+
-+# Returns the path to the Ren'Py base directory (containing common and
-+# the launcher, usually.)
-+def path_to_renpy_base():
-+ renpy_base = os.path.dirname(os.path.realpath(sys.argv[0]))
-+ renpy_base = get_python_lib() + "/renpy@SLOT@"
-+ renpy_base = os.path.abspath(renpy_base)
-+
-+ return renpy_base
---- renpy/main.py
-+++ renpy/main.py
-@@ -25,7 +25,7 @@ import os
- import sys
- import time
- import zipfile
--import __main__
-+import renpy.common as common
-
-
- def run(restart):
-@@ -167,7 +167,7 @@ def main():
- renpy.config.searchpath = [ renpy.config.gamedir ]
-
- # Find the common directory.
-- commondir = __main__.path_to_common(renpy.config.renpy_base) # E1101 @UndefinedVariable
-+ commondir = common.path_to_common(renpy.config.renpy_base) # E1101 @UndefinedVariable
-
- if os.path.isdir(commondir):
- renpy.config.searchpath.append(commondir)
-@@ -230,7 +230,7 @@ def main():
-
- # Find the save directory.
- if renpy.config.savedir is None:
-- renpy.config.savedir = __main__.path_to_saves(renpy.config.gamedir) # E1101 @UndefinedVariable
-+ renpy.config.savedir = common.path_to_saves(renpy.config.gamedir) # E1101 @UndefinedVariable
-
- if renpy.game.args.savedir: #@UndefinedVariable
- renpy.config.savedir = renpy.game.args.savedir #@UndefinedVariable