summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-09-09 23:05:48 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-09-09 23:05:48 +0100
commit2c5f5b7682e49e3f140632b6f8b03d3226ed3dc1 (patch)
tree818130ddaf1996cd28c01207dc6da2689b7410dc /games-engines
parentgames-engines/odamex: Add ~arm keyword (diff)
downloadgentoo-2c5f5b7682e49e3f140632b6f8b03d3226ed3dc1.tar.gz
gentoo-2c5f5b7682e49e3f140632b6f8b03d3226ed3dc1.tar.bz2
gentoo-2c5f5b7682e49e3f140632b6f8b03d3226ed3dc1.zip
games-engines/odamex: Search our usual data directory and prefix paths
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/odamex/files/odamex-0.8.1-SearchDir.patch11
-rw-r--r--games-engines/odamex/odamex-0.8.1-r1.ebuild (renamed from games-engines/odamex/odamex-0.8.1.ebuild)4
2 files changed, 14 insertions, 1 deletions
diff --git a/games-engines/odamex/files/odamex-0.8.1-SearchDir.patch b/games-engines/odamex/files/odamex-0.8.1-SearchDir.patch
new file mode 100644
index 000000000000..70bd476eb3f2
--- /dev/null
+++ b/games-engines/odamex/files/odamex-0.8.1-SearchDir.patch
@@ -0,0 +1,11 @@
+diff -Naur a/common/d_main.cpp b/common/d_main.cpp
+--- a/common/d_main.cpp 2019-07-22 19:11:28.000000000 +0100
++++ b/common/d_main.cpp 2019-09-09 22:57:47.624246017 +0100
+@@ -459,6 +459,7 @@
+ D_AddSearchDir(dirs, INSTALL_PREFIX "/" INSTALL_DATADIR "/games/odamex", separator);
+ #endif
+
++ D_AddSearchDir(dirs, "/usr/share/doom", separator);
+ D_AddSearchDir(dirs, "/usr/share/games/doom", separator);
+ D_AddSearchDir(dirs, "/usr/local/share/games/doom", separator);
+ D_AddSearchDir(dirs, "/usr/local/share/doom", separator);
diff --git a/games-engines/odamex/odamex-0.8.1.ebuild b/games-engines/odamex/odamex-0.8.1-r1.ebuild
index dbf54b31f41a..a4aa73ce963d 100644
--- a/games-engines/odamex/odamex-0.8.1.ebuild
+++ b/games-engines/odamex/odamex-0.8.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit cmake-utils desktop wxwidgets xdg
+inherit cmake-utils desktop prefix wxwidgets xdg
DESCRIPTION="Online multiplayer free software engine for DOOM"
HOMEPAGE="https://odamex.net/"
@@ -35,10 +35,12 @@ S="${WORKDIR}/${PN}-src-${PV}"
PATCHES=(
"${FILESDIR}"/${P}-miniupnpc.patch
+ "${FILESDIR}"/${P}-SearchDir.patch
)
src_prepare() {
rm -r libraries/libminiupnpc odamex.wad || die
+ hprefixify common/d_main.cpp
use odalaunch && setup-wxwidgets