summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Pihl <ahvenas@gmail.com>2020-07-10 19:45:50 +0300
committerJames Le Cuirot <chewi@gentoo.org>2020-07-19 12:49:29 +0100
commit397539cf575103d062648e38d9f2bdb80e0bed46 (patch)
tree7ab53f2a4acfd8d293cc3148d1115d0e880b61dd /games-engines
parentnet-p2p/nicotine+: 2.0.1-r1: py37 added; xdg_icon_cache_update in postrm added. (diff)
downloadgentoo-397539cf575103d062648e38d9f2bdb80e0bed46.tar.gz
gentoo-397539cf575103d062648e38d9f2bdb80e0bed46.tar.bz2
gentoo-397539cf575103d062648e38d9f2bdb80e0bed46.zip
games-engines/scummvm: Bump to 2.1.2
TTS patch removed, already merged upstream. Bug: https://bugs.gentoo.org/708600 Signed-off-by: Henrik Pihl <ahvenas@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16659 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/Manifest1
-rw-r--r--games-engines/scummvm/scummvm-2.1.2.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 75b986c1944c..dd160ccc1dd2 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1 +1,2 @@
DIST scummvm-2.1.0.tar.xz 27188916 BLAKE2B b808ff335e5b25c58c8caebfe660b4c2938dcb6eada0aa5b31777b97ff2fb7cb3732d516fc4d981ab1bee16876d62f634f69517158c7c233e11cc22575b15c09 SHA512 9a03cf207660aa49e49f53e1df10b774b7c9711dffd527e00518015e7e7057f25538a7dd89e248e9237434cf08a9f7ea6b215805fb65a770fb20596f5e713218
+DIST scummvm-2.1.2.tar.xz 27056972 BLAKE2B 0afedd27350ea80c3610106b7e09fd57aaebc8847eebdb180628559ca30f49d005a5466bd3991a76271eff39a782e8abf3bf1a3ace25909a1d9947a1b539d6c2 SHA512 a6462bc55d90a229e32389380504d6ecf0c836c8a6733775c993f8db34918ef1f9d0559acc7c110e98719b32cf84408a01021dcfa3fe5a821fe4265c1bc49ecc
diff --git a/games-engines/scummvm/scummvm-2.1.2.ebuild b/games-engines/scummvm/scummvm-2.1.2.ebuild
new file mode 100644
index 000000000000..d0636f9429d1
--- /dev/null
+++ b/games-engines/scummvm/scummvm-2.1.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="https://www.scummvm.org/"
+SRC_URI="https://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="a52 aac alsa debug flac fluidsynth jpeg lua mpeg2 mp3 net opengl png speech theora truetype unsupported vorbis zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.0[sound,joystick,video]
+ a52? ( media-libs/a52dec )
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )
+ jpeg? ( virtual/jpeg:0 )
+ mp3? ( media-libs/libmad )
+ mpeg2? ( media-libs/libmpeg2 )
+ net? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ png? ( media-libs/libpng:0 )
+ speech? ( app-accessibility/speech-dispatcher )
+ truetype? ( media-libs/freetype:2 )
+ theora? ( media-libs/libtheora )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ truetype? ( virtual/pkgconfig )
+ x86? ( dev-lang/nasm )
+"
+
+S="${WORKDIR}/${P/_/}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0-fluidsynth.patch"
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ local myconf=(
+ --backend=sdl
+ --host=${CHOST}
+ --enable-verbose-build
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --opengl-mode=$(usex opengl auto none)
+ $(use_enable a52)
+ $(use_enable aac faad)
+ $(use_enable alsa)
+ $(use_enable debug)
+ $(use_enable !debug release-mode)
+ $(use_enable flac)
+ $(usex fluidsynth '' --disable-fluidsynth)
+ $(use_enable jpeg)
+ $(use_enable lua)
+ $(use_enable mp3 mad)
+ $(use_enable mpeg2)
+ $(use_enable net sdlnet)
+ $(use_enable png)
+ $(use_enable speech tts)
+ $(use_enable theora theoradec)
+ $(use_enable truetype freetype2)
+ $(usex unsupported --enable-all-engines '')
+ $(use_enable vorbis)
+ $(use_enable zlib)
+ $(use_enable x86 nasm)
+ )
+ echo "configure ${myconf[@]}"
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ SDL_CONFIG="sdl2-config" \
+ ./configure "${myconf[@]}" "${EXTRA_ECONF}" || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR) cru" RANLIB="$(tc-getRANLIB)"
+}
+
+src_install() {
+ default
+ doicon -s scalable icons/scummvm.svg
+}