summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-10-12 01:51:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-10-13 13:46:38 +0300
commit50a85e0526588898a5fc124820ee93df9865faa0 (patch)
tree685f600bec724088799d744725701545993bb0f7 /games-engines
parentgames-engines/openmw: update the 9999-only patch (diff)
downloadgentoo-50a85e0526588898a5fc124820ee93df9865faa0.tar.gz
gentoo-50a85e0526588898a5fc124820ee93df9865faa0.tar.bz2
gentoo-50a85e0526588898a5fc124820ee93df9865faa0.zip
games-engines/openmw: restrict double-precisionness of bullet
For 0.46.0, require no double precision. For 9999, require double precision instead. Upstream references: https://github.com/OpenMW/openmw/pull/2049 https://github.com/OpenMW/openmw/pull/2848 Closes: https://bugs.gentoo.org/747898 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17896 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/openmw/openmw-0.46.0.ebuild2
-rw-r--r--games-engines/openmw/openmw-9999.ebuild3
2 files changed, 3 insertions, 2 deletions
diff --git a/games-engines/openmw/openmw-0.46.0.ebuild b/games-engines/openmw/openmw-0.46.0.ebuild
index abb4174bc5fe..5de3fb3d92af 100644
--- a/games-engines/openmw/openmw-0.46.0.ebuild
+++ b/games-engines/openmw/openmw-0.46.0.ebuild
@@ -36,7 +36,7 @@ RDEPEND="
media-libs/libsdl2[joystick,opengl,video]
media-libs/openal
media-video/ffmpeg:=
- >=sci-physics/bullet-2.86:=
+ >=sci-physics/bullet-2.86:=[-double-precision]
virtual/opengl
osg-fork? ( dev-games/openscenegraph-openmw:=[ffmpeg,jpeg,png,sdl,svg,truetype,zlib] )
!osg-fork? ( >=dev-games/openscenegraph-3.5.5:=[ffmpeg,jpeg,png,sdl,svg,truetype,zlib] )
diff --git a/games-engines/openmw/openmw-9999.ebuild b/games-engines/openmw/openmw-9999.ebuild
index 1183e5459a13..70603fec46ab 100644
--- a/games-engines/openmw/openmw-9999.ebuild
+++ b/games-engines/openmw/openmw-9999.ebuild
@@ -33,7 +33,7 @@ RDEPEND="
media-libs/libsdl2[joystick,opengl,video]
media-libs/openal
media-video/ffmpeg:=
- >=sci-physics/bullet-2.86:=
+ >=sci-physics/bullet-2.86:=[double-precision]
virtual/opengl
osg-fork? ( dev-games/openscenegraph-openmw:=[ffmpeg,jpeg,png,sdl,svg,truetype,zlib] )
!osg-fork? ( >=dev-games/openscenegraph-3.5.5:=[ffmpeg,jpeg,png,sdl,svg,truetype,zlib] )
@@ -96,6 +96,7 @@ src_configure() {
-DMORROWIND_DATA_FILES="${EPREFIX}/usr/share/morrowind-data"
-DUSE_SYSTEM_TINYXML=ON
-DDESIRED_QT_VERSION=5
+ -DBULLET_USE_DOUBLES=ON
)
cmake_src_configure