summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/enemy-territory
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/enemy-territory')
-rw-r--r--games-fps/enemy-territory/Manifest3
-rw-r--r--games-fps/enemy-territory/enemy-territory-2.60b-r1.ebuild119
-rw-r--r--games-fps/enemy-territory/metadata.xml8
3 files changed, 130 insertions, 0 deletions
diff --git a/games-fps/enemy-territory/Manifest b/games-fps/enemy-territory/Manifest
new file mode 100644
index 000000000000..7210d7428350
--- /dev/null
+++ b/games-fps/enemy-territory/Manifest
@@ -0,0 +1,3 @@
+DIST ET-2.60b.zip 4143401 SHA256 6fb77e1ed0314b2da5c2a28807392ac638204faec8ef86361893937f182b22f8 SHA512 f86d0d172a170cd894f1c60a817d2159768bf7d03cb0146f3470edd54828096a62e890c24bac80a5851adc9356cb2716d5f0c756fab063a9c0eb561b72825b84 WHIRLPOOL 6e4718051b77201b5bdb87efebd492db46ca83cca380b7f4bac2833d3f95700a39801cfcd5b025ed2b4c51d6b3140b7a2021ba8e1056bf4d100e67204768170b
+DIST enemy-territory-all-0.1.tar.bz2 876 SHA256 8c3466db348eccd34bd108db57bc6fb656a7dcbacd190cc331fd8caf74c7cb64 SHA512 7e00ac4a30ebbbc5db646e0edf6683d8e4d99756c1010922ccfd16a3dc27c0a5b23a91c9f3adb3e120bfcd5f9a3302a466a86888ff1496dda29a3b09e87eacb2 WHIRLPOOL 1dec8052196a04a3cf834636bab54a15a0eceee2eb52df888a533fe4f78a3f774eb122d6b14d65738b9084b7d543d26ab3d9ef14cafd63a1ba68e50e60d63307
+DIST et-linux-2.60.x86.run 270965248 SHA256 41cbbc1afb8438bc8fc74a64a171685550888856005111cbf9af5255f659ae36 SHA512 7321a3d831dd375c49aff81f30098c5201880e9fc783a25dd7dee3bd2211372e0e07a482e6c78982bc1f27d62bceb769dffc30f820c3144b4a64268fd9ef5cfe WHIRLPOOL 43e4cdced441add2524e07412d06a5530627922b14549f847567b9e558eb7652f7a7c8b6dac26b5ed6c18f55597a8cf898c950026dcd0577731d86257ae59162
diff --git a/games-fps/enemy-territory/enemy-territory-2.60b-r1.ebuild b/games-fps/enemy-territory/enemy-territory-2.60b-r1.ebuild
new file mode 100644
index 000000000000..df3e8f17ecbe
--- /dev/null
+++ b/games-fps/enemy-territory/enemy-territory-2.60b-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="standalone multi-player game based on Return to Castle Wolfenstein"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="mirror://3dgamers/wolfensteinet/et-linux-2.60.x86.run
+ mirror://idsoftware/et/linux/et-linux-2.60.x86.run
+ ftp://ftp.red.telefonica-wholesale.net/GAMES/ET/linux/et-linux-2.60.x86.run
+ mirror://idsoftware/et/ET-${PV}.zip
+ dedicated? (
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}-all-0.1.tar.bz2
+ mirror://gentoo/${PN}-all-0.1.tar.bz2
+ )"
+
+LICENSE="RTCW-ETEULA"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="dedicated"
+RESTRICT="mirror strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ dedicated? ( app-misc/screen )
+ !dedicated? (
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_PREBUILT="
+ ${dir:1}/et.x86
+ ${dir:1}/etmain/cgame.mp.i386.so
+ ${dir:1}/etmain/qagame.mp.i386.so
+ ${dir:1}/etmain/ui.mp.i386.so
+ ${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbags.so
+ ${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbsv.so
+ ${dir:1}/pb/pbweb.x86"
+
+src_unpack() {
+ unpack_makeself et-linux-2.60.x86.run
+ if use dedicated; then
+ unpack ${PN}-all-0.1.tar.bz2
+ fi
+ unpack ET-${PV}.zip
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe openurl.sh
+
+ insinto "${dir}"
+ dodoc CHANGES README
+
+ cp -r Docs pb etmain "${Ddir}" || die
+ chmod og+x "${Ddir}"/pb/pbweb.x86 || die
+
+ if ! use dedicated ; then
+ doicon ET.xpm
+ doexe "Enemy Territory 2.60b"/linux/et.x86
+ games_make_wrapper et ./et.x86 "${dir}" "${dir}"
+ make_desktop_entry et "Enemy Territory" ET
+ else
+ doexe "Enemy Territory 2.60b"/linux/etded.x86
+ games_make_wrapper et-ded ./etded.x86 "${dir}"
+ newinitd "${S}"/et-ded.rc et-ded
+ sed -i \
+ -e "s:GAMES_USER_DED:${GAMES_USER_DED}:" \
+ -e "s:GENTOO_DIR:${GAMES_BINDIR}:" \
+ "${D}"/etc/init.d/et-ded || die
+ newconfd "${S}"/et-ded.conf.d et-ded
+ # TODO: move this to /var/ perhaps ?
+ keepdir "${dir}/etwolf-homedir"
+ chmod g+rw "${Ddir}/etwolf-homedir"
+ dosym "${dir}/etwolf-homedir" "${GAMES_PREFIX}/.etwolf"
+ fi
+
+ prepgamesdirs
+ chmod g+rw "${Ddir}" "${Ddir}/etmain"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "There are two possible security bugs in this package, both causing a"
+ ewarn "denial of service. One affects the game when running a server, the"
+ ewarn "other when running as a client."
+ ewarn "For more information, see bug #82149."
+ echo
+ if ! use dedicated; then
+ elog "To play the game run:"
+ elog " et"
+ echo
+ else
+ elog "To start a dedicated server run:"
+ elog " /etc/init.d/et-ded start"
+ echo
+ elog "To run the dedicated server at boot, type:"
+ elog " rc-update add et-ded default"
+ echo
+ elog "The dedicated server is started under the ${GAMES_USER_DED} user account."
+ echo
+ ewarn "Store your configurations under ${dir}/etwolf-homedir or they"
+ ewarn "will be erased on the next upgrade."
+ ewarn "See bug #132795 for more info."
+ echo
+ fi
+}
diff --git a/games-fps/enemy-territory/metadata.xml b/games-fps/enemy-territory/metadata.xml
new file mode 100644
index 000000000000..d45982b39d58
--- /dev/null
+++ b/games-fps/enemy-territory/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Enemy Territory is a first-person 3-D shooter based loosely on the original Wolfenstein series by id software. The game takes place in North Africa and Europe during World War II and allows you to play as either the Axis or the Allies. There are several classes of characters you can play, each with their own special abilities and weapon choices. You can also gain proficiency in your specialties and increase your abilities by performing your class's specialized duties, which helps promote teamwork. Enemy Territory was originally to be a single and milti-player add-on for Return to Castle Wofenstein, but John Carmack and company were not happy with the progress they had made on it, so instead, they released it as a multi-player stand-alone game.
+</longdescription>
+</pkgmetadata>