summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/rtcwmp-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/rtcwmp-demo')
-rw-r--r--games-fps/rtcwmp-demo/Manifest1
-rw-r--r--games-fps/rtcwmp-demo/files/rtcwmp-demo-ded.rc25
-rw-r--r--games-fps/rtcwmp-demo/metadata.xml8
-rw-r--r--games-fps/rtcwmp-demo/rtcwmp-demo-1.1-r1.ebuild74
4 files changed, 108 insertions, 0 deletions
diff --git a/games-fps/rtcwmp-demo/Manifest b/games-fps/rtcwmp-demo/Manifest
new file mode 100644
index 000000000000..c0ab460b553b
--- /dev/null
+++ b/games-fps/rtcwmp-demo/Manifest
@@ -0,0 +1 @@
+DIST wolfmpdemo-linux-1.1-MP.x86.run 69650634 SHA256 44638cf2d98db4ac583aa4878645e171a7c4b462b44961629aeb8d8d78188da8 SHA512 2e497ca8cb0552dfbc90bfd10544b44f0dca2b7dc74ad6428041fd9885926a03cfdae72d6e5ccbd61b0d0c5b051355c567a9101746838110ebeb0f3fdcaf3ad5 WHIRLPOOL 6087920c0d63f5060292adcb575fafb1113b82e9e8e1a557cf740c649dad7b54ae4fae44ce698ccdcfafa4749964ad174cd3731634235fa0f27ece375a67a5ca
diff --git a/games-fps/rtcwmp-demo/files/rtcwmp-demo-ded.rc b/games-fps/rtcwmp-demo/files/rtcwmp-demo-ded.rc
new file mode 100644
index 000000000000..bae1e6744284
--- /dev/null
+++ b/games-fps/rtcwmp-demo/files/rtcwmp-demo-ded.rc
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting RTCW demo dedicated server..."
+ screen -A -m -d -S rtcwdemo su - dedicated -c GENTOO_DIR/startrtcwded
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping RTCW demo dedicated server..."
+ kill `screen -list | grep rtcwdemo | awk -F . '{ print $1 }' | sed -e s/.//`
+ eend $?
+
+}
+
+status() {
+ screen -list | grep rtcwdemoded
+}
diff --git a/games-fps/rtcwmp-demo/metadata.xml b/games-fps/rtcwmp-demo/metadata.xml
new file mode 100644
index 000000000000..bf237e2b6f2e
--- /dev/null
+++ b/games-fps/rtcwmp-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+The sequel to id Software's classic Wolfenstein 3-D. This version of the demo is only for multi-player.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/rtcwmp-demo/rtcwmp-demo-1.1-r1.ebuild b/games-fps/rtcwmp-demo/rtcwmp-demo-1.1-r1.ebuild
new file mode 100644
index 000000000000..bf995cdbda55
--- /dev/null
+++ b/games-fps/rtcwmp-demo/rtcwmp-demo-1.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="wolfmpdemo-linux-${PV}-MP.x86.run"
+
+DESCRIPTION="Return to Castle Wolfenstein - Multi-player demo"
+HOMEPAGE="http://games.activision.com/games/wolfenstein/"
+SRC_URI="mirror://idsoftware/wolf/linux/old/${MY_P}
+ mirror://3dgamers/returnwolfenstein/${MY_P}"
+
+LICENSE="RTCW GPL-2" # gpl for init script bug #425946
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="dedicated"
+RESTRICT="strip mirror"
+
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ dedicated? ( app-misc/screen )
+ !dedicated? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}/{PN}/*
+ ${GAMES_PREFIX_OPT:1}/{PN}/demomain/*"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_install() {
+ insinto "${dir}"
+ doins -r demomain Docs
+ doins WolfMP.xpm
+ dodoc CHANGES QUICKSTART
+
+ exeinto "${dir}"
+ doexe bin/x86/wolfded.x86 openurl.sh
+ games_make_wrapper rtcwmp-demo-ded ./wolfded.x86 "${dir}" "${dir}"
+ newinitd "${FILESDIR}"/rtcwmp-demo-ded.rc rtcwmp-demo-ded
+ sed "s:GENTOO_DIR:${dir}:" "${ED}"/etc/init.d/rtcwmp-demo-ded || die
+
+ if ! use dedicated; then
+ doexe bin/x86/wolf.x86
+ games_make_wrapper rtcwmp-demo ./wolf.x86 "${dir}" "${dir}"
+ newicon WolfMP.xpm rtcwmp-demo.xpm
+ make_desktop_entry rtcwmp-demo "Return to Castle Wolfenstein (MP demo)" \
+ rtcwmp-demo.xpm
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Install 'rtcwsp-demo' for single-player"
+ elog
+ if ! use dedicated; then
+ elog "Run 'rtcwmp-demo' for multi-player"
+ elog
+ fi
+ elog "Start a dedicated server with"
+ elog "'/etc/init.d/rtcwmp-demo-ded start'"
+ elog
+ elog "Start the server at boot with"
+ elog "'rc-update add rtcwmp-demo-ded default'"
+}