summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2004-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2004-demo')
-rw-r--r--games-fps/ut2004-demo/Manifest1
-rw-r--r--games-fps/ut2004-demo/metadata.xml5
-rw-r--r--games-fps/ut2004-demo/ut2004-demo-3334.ebuild85
3 files changed, 91 insertions, 0 deletions
diff --git a/games-fps/ut2004-demo/Manifest b/games-fps/ut2004-demo/Manifest
new file mode 100644
index 000000000000..1acc90662366
--- /dev/null
+++ b/games-fps/ut2004-demo/Manifest
@@ -0,0 +1 @@
+DIST ut2004-lnx-demo3334.run 288950743 SHA256 c7065a758e91fdf5cf79cb8f9646e4360928ba9de4460ab7011c08e22a240cf3 SHA512 4cdd61901f4c082d1e02caf301a24f1e18e89f4efc9fbce0e4496178916b6c14245131b62f27deb17f1763cd4b8bf68ee60cc7af5ece5fa2b39d1bf349361da0 WHIRLPOOL 07749d100e601967ed581725290f67479252a4a5393b43d44037513776306432d20e1ed7cc05fa747be90cd04065eb3ba6484095d630c9ceea599d8f83b429a9
diff --git a/games-fps/ut2004-demo/metadata.xml b/games-fps/ut2004-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/ut2004-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/ut2004-demo/ut2004-demo-3334.ebuild b/games-fps/ut2004-demo/ut2004-demo-3334.ebuild
new file mode 100644
index 000000000000..7fa399204833
--- /dev/null
+++ b/games-fps/ut2004-demo/ut2004-demo-3334.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="ut2004-lnx-demo${PV}.run"
+DESCRIPTION="Demo for the critically-acclaimed first-person shooter"
+HOMEPAGE="http://www.unrealtournament.com/"
+SRC_URI="mirror://gentoo/${MY_P}"
+
+LICENSE="ut2003-demo"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ virtual/libstdc++:3.3
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/System/*"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./setupstuff.tar.gz
+}
+
+src_install() {
+ dodir "${dir}"
+
+ tar xjf ut2004demo.tar.bz2 -C "${Ddir}" || die
+
+ if use x86
+ then
+ tar xjf linux-x86.tar.bz2 || die
+ fi
+ if use amd64
+ then
+ tar xjf linux-amd64.tar.bz2 || die
+ fi
+
+ insinto "${dir}"
+ doins README.linux ut2004.xpm
+ newicon ut2004.xpm ut2004-demo.xpm
+
+ exeinto "${dir}"
+ doexe bin/ut2004-demo
+
+ exeinto "${dir}"/System
+ doexe System/{libSDL-1.2.so.0,openal.so,ucc-bin,ut2004-bin}
+
+ games_make_wrapper ut2004-demo ./ut2004-demo "${dir}" "${dir}"
+ make_desktop_entry ut2004-demo "Unreal Tournament 2004 (Demo)" ut2004-demo
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For Text To Speech:"
+ elog " 1) emerge festival speechd"
+ elog " 2) Edit your ~/.ut2004demo/System/UT2004.ini file."
+ elog " In the [SDLDrv.SDLClient] section, add:"
+ elog " TextToSpeechFile=/dev/speech"
+ elog " 3) Start speechd."
+ elog " 4) Start the game. Be sure to go into the Audio"
+ elog " options and enable Text To Speech."
+ echo
+ elog "To test, pull down the console (~) and type:"
+ elog " TTS this is a test."
+ echo
+ elog "You should hear something that sounds like 'This is a test.'"
+ echo
+}