summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 11:15:05 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:37 +0200
commit12aeb6ffe88b98c9a5ba66d9a9905c5a51b5505d (patch)
tree3f4dfcce17e56346b0c4083ed1db49ee3e91eba2 /games-fps
parentgames-fps/openarena: Drop old (diff)
downloadgentoo-12aeb6ffe88b98c9a5ba66d9a9905c5a51b5505d.tar.gz
gentoo-12aeb6ffe88b98c9a5ba66d9a9905c5a51b5505d.tar.bz2
gentoo-12aeb6ffe88b98c9a5ba66d9a9905c5a51b5505d.zip
games-fps/transfusion-bin: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/transfusion-bin/transfusion-bin-1.01-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-fps/transfusion-bin/transfusion-bin-1.01-r1.ebuild b/games-fps/transfusion-bin/transfusion-bin-1.01-r1.ebuild
new file mode 100644
index 000000000000..a535a8e3f9c6
--- /dev/null
+++ b/games-fps/transfusion-bin/transfusion-bin-1.01-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_PN="${PN/-bin/}"
+DESCRIPTION="Blood remake"
+HOMEPAGE="http://www.transfusion-game.com/"
+SRC_URI="mirror://sourceforge/blood/${MY_PN}-1.0-linux.i386.zip
+ mirror://sourceforge/blood/${MY_PN}-patch-${PV}-linux.i386.zip
+ mirror://gentoo/${MY_PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}"
+
+dir="/opt/${MY_PN}"
+Ddir="${D}/${dir}"
+
+src_install() {
+ # install everything that looks anything like docs...
+ dodoc ${MY_PN}/doc/*.txt ${MY_PN}/*txt qw/*txt
+ HTML_DOCS="${MY_PN}/doc/*.html" einstalldocs
+
+ #...then mass copy everything to the install dir...
+ dodir "${dir}"
+ cp -R * "${Ddir}" || die
+
+ # ...and remove the docs since we don't need them installed twice.
+ rm -rf \
+ "${Ddir}"/${MY_PN}/doc \
+ "${Ddir}"/qw/*txt \
+ "${Ddir}"/${MY_PN}/*txt
+
+ doicon "${DISTDIR}"/${MY_PN}.png
+ make_wrapper ${MY_PN} ./${MY_PN}-glx "${dir}" "${dir}"
+ make_desktop_entry ${MY_PN} "Transfusion" ${MY_PN}
+}