summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 00:09:41 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 01:48:16 -0500
commit4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3 (patch)
treea680ce94a991b48c31699c5dd1749991b49581ff /games-fps
parentgames-fps/doom3-ducttape: EAPI=5 (diff)
downloadgentoo-4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3.tar.gz
gentoo-4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3.tar.bz2
gentoo-4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3.zip
games-fps/doom3-ducttape: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom3-ducttape/Manifest1
-rw-r--r--games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/games-fps/doom3-ducttape/Manifest b/games-fps/doom3-ducttape/Manifest
index b6851e2f22d3..077182768182 100644
--- a/games-fps/doom3-ducttape/Manifest
+++ b/games-fps/doom3-ducttape/Manifest
@@ -1 +1,2 @@
DIST ducttape0006.zip 65641 SHA256 2bd694dddc49466defbf8ac2cf32b1778145900cec1e7c255d91c050ae6b7423 SHA512 57b7be6cbe38db8a93f3af68b9f08d09d28a3507f8408c0235d31edb8b670aeca034a161cfe88ba6b9174cbef86420cc6f7e5a5547d2bb1e1182958e5ec804df WHIRLPOOL 04dd51d5d48075e9dc33b6a38667c343837432f7a2ac5398d1773a74b67c146cdfdbb6c51e7369ead865f8da65a46540fa42d23b7d890b9a50b286049bcb0950
+DIST ducttape0007.zip 66501 SHA256 5a23113075cbb7b9219b8506bf657ba4c887657fa877dc496454d47fd43ba3fd SHA512 90c2a271881b3cc7823be5f01b0809d99aabb6f8a88c9a3806d6b4adc0f86a9a0f63cd34498fcd99ff1eb25de4271aac5912495a469bbb72d4b9ae7b90f003a2 WHIRLPOOL 24db1d3b874dca8b8a2144e295b5c7d8f27955274877a461552aea9e9b0753c5afdb0e405c98b20cc32d28086d304f172558a2e45de7d33fbbe7caf51b5a8894
diff --git a/games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild b/games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild
new file mode 100644
index 000000000000..95896973c82e
--- /dev/null
+++ b/games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MOD_DESC="sticks flashlights to your machinegun and shotgun"
+MOD_NAME="Duct Tape"
+MOD_DIR="ducttape"
+
+inherit games games-mods
+
+HOMEPAGE="http://ducttape.glenmurphy.com/"
+SRC_URI="http://ducttape.glenmurphy.com/ducttape${PV}.zip"
+
+LICENSE="freedist"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+
+src_unpack() {
+ mkdir ${MOD_DIR} || die
+ cd ${MOD_DIR} || die
+ unpack ${A}
+}
+
+src_prepare() {
+ rm -f ${MOD_DIR}/pak002.pk4 || die # for doom3-roe
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+
+ elog "To use old saved games with this mod, run:"
+ elog " mkdir -p ~/.doom3/ducttape"
+ elog " cp -r ~/.doom3/base/savegames ~/.doom3/ducttape"
+}