summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-fps
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doomsday/doomsday-2.1.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-fps/doomsday/doomsday-2.1.1.ebuild b/games-fps/doomsday/doomsday-2.1.1.ebuild
index 757a7f8c4729..8eb5fd81fbea 100644
--- a/games-fps/doomsday/doomsday-2.1.1.ebuild
+++ b/games-fps/doomsday/doomsday-2.1.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit cmake-utils python-any-r1 readme.gentoo-r1
+inherit cmake python-any-r1 readme.gentoo-r1
DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
HOMEPAGE="https://www.dengine.net"
@@ -45,7 +45,7 @@ S="${WORKDIR}/${P}/${PN}"
DOC_CONTENTS="You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD, or Doom64 wads to a folder of your choice and then tell the game engine where that folder is. This is different to older versions, which had separate launchers for each game and required the files to be in a specific place."
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Fix QA warning for "installing to one or more unexpected paths"
sed -e "10s:/texc:/${PF}:" -i tools/texc/CMakeLists.txt || die
@@ -58,11 +58,11 @@ src_configure() {
-DDENG_ENABLE_TOOLS="$(usex tools)"
-DPYTHON_EXECUTABLE="${PYTHON}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use tools; then
mv -v "${ED}"/usr/bin/md2tool{,.${PN}} || die