summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-13 13:03:13 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-13 13:15:07 -0500
commit82de58a08e3b4d65292171d822751066bd430946 (patch)
tree595e515a57fa67f394881f23bc3e3967c9915263 /games-fps
parentsys-apps/openrc: sync live ebuild (diff)
downloadgentoo-82de58a08e3b4d65292171d822751066bd430946.tar.gz
gentoo-82de58a08e3b4d65292171d822751066bd430946.tar.bz2
gentoo-82de58a08e3b4d65292171d822751066bd430946.zip
games-fps/doom3-mitm: EAPI=5; attempt at fixing bug #383321
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom3-mitm/Manifest3
-rw-r--r--games-fps/doom3-mitm/doom3-mitm-20070129.ebuild19
2 files changed, 10 insertions, 12 deletions
diff --git a/games-fps/doom3-mitm/Manifest b/games-fps/doom3-mitm/Manifest
index 4dbc77b42c1f..6d2ac8829ec5 100644
--- a/games-fps/doom3-mitm/Manifest
+++ b/games-fps/doom3-mitm/Manifest
@@ -1,2 +1 @@
-DIST mitm5.zip 33650739 SHA256 e514c37cc8efc19cac8dc9b55ffae7c98f41aecd6855d3ba8206768ef6167f9d
-DIST mitm_4.zip 136302315 SHA256 a93b65ccb92f3839e9824d00a439e67ecf8c643e1b1d15789b08070d47fa7938
+DIST MakeItToMorning1-6.zip 184131772 SHA256 d9757e51f6d474fe992b19008d2723253f27496baea6729576e460c3c31b0e64 SHA512 5c8b58b51fb4308366db74705c6f1c5ed7a99f41992000c0ceb3b57fe1d61cb617cc03725ab213d6d7cfbad76104efebe647e50d5ad78e5b0ec480ed840118ea WHIRLPOOL 24317336168b2bc3d05582ed745858597f4248fc3261f102de8ca539641574221cd39850ef83f0ee422038ed43422801cf87c80330c1d85d35432bf23e2ebdf1
diff --git a/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild b/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild
index f00fa71844e9..4b84e9e171b8 100644
--- a/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild
+++ b/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild
@@ -9,35 +9,34 @@ MOD_NAME="Make it to Morning"
inherit eutils games games-mods
-HOMEPAGE="http://www.makeittomorning.co.uk/"
-SRC_URI="http://www.doomwadstation.com/doom3/maps/Morning/mitm_4.zip
- http://www.doomwadstation.com/doom3/maps/Morning/mitm5.zip"
+HOMEPAGE="http://www.jimwilkie.co.uk/mitm/"
+SRC_URI="MakeItToMorning1-6.zip"
LICENSE="all-rights-reserved"
KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="fetch"
RDEPEND="games-fps/doom3-roe
games-fps/doom3[opengl,roe]"
+pkg_nofetch() {
+ elog "Go to http://www.gamewatcher.com/mods/doom-3-resurrection-of-evil-mod/make-it-to-morning-1-6"
+ elog "and download ${A} and place the file in ${DISTDIR}"
+}
+
src_unpack() {
mkdir mitm || die
cd mitm || die
unpack ${A}
}
-src_prepare() {
- cd mitm || die
- mv -f MITM*.txt mitm.txt || die
- mv -f Mitm5*.txt mitm5.txt || die
-}
-
src_install() {
games_make_wrapper ${PN} \
"doom3 +set fs_game_base d3xp +set fs_game mitm +map mitm"
make_desktop_entry ${PN} "Doom 3 - ${MOD_NAME} (1)" doom3
local i
- for i in {2..5} ; do
+ for i in {2..6} ; do
games_make_wrapper ${PN}${i} \
"doom3 +set fs_game_base d3xp +set fs_game mitm +map mitm${i}"
make_desktop_entry ${PN}${i} "Doom 3 - ${MOD_NAME} (${i})" doom3