summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 15:20:14 +0000
committerSam James <sam@gentoo.org>2021-01-12 15:22:05 +0000
commit966ceefb3283f34d7f82fb5a92f5028e1dcc4834 (patch)
treea7a40791daf15f3bddf71b5307147f3eb1dba839 /games-fps
parentgames-fps/doomsday: add Python 3.8, 3.9 (diff)
downloadgentoo-966ceefb3283f34d7f82fb5a92f5028e1dcc4834.tar.gz
gentoo-966ceefb3283f34d7f82fb5a92f5028e1dcc4834.tar.bz2
gentoo-966ceefb3283f34d7f82fb5a92f5028e1dcc4834.zip
games-fps/doomsday: bump to 2.3.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doomsday/Manifest1
-rw-r--r--games-fps/doomsday/doomsday-2.3.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/games-fps/doomsday/Manifest b/games-fps/doomsday/Manifest
index 4726ace45e3f..e6ef0b454e32 100644
--- a/games-fps/doomsday/Manifest
+++ b/games-fps/doomsday/Manifest
@@ -1 +1,2 @@
DIST doomsday-2.1.1.tar.gz 47526008 BLAKE2B bf941048d160058273df09d67b09e140c10d141cd73ff56d0f3162045696d81533aba9a8c9ff39fc29530248ee8b2f6dd2b3da76a929fb6263c311e65bcbdd82 SHA512 9df0afa0465ef3c3bb30cccf8ca51596e8e6e5584775a695c9c3278f15bcf7e9f7aaeaa0917f0a1de9fbb1174f2ae83a1ee85fba63bef6e49be957836f1107a3
+DIST doomsday-2.3.0.tar.gz 47838189 BLAKE2B 807204cd5e716f57291e383b6a2f0570c01f3e4a92d575f5e585cf1e793785031edd845399dd6896766b1c77425b2fefd6f5f5913adc5fcb7bb1415b2f906c98 SHA512 46d92743e981804eca3ed6e486c4a748114621053d6269a0c0bc5fa84a591f6556ad3226ab6fb3cbc8642ac2f128885261c0bdc78bb5f2012a25f2cab6413461
diff --git a/games-fps/doomsday/doomsday-2.3.0.ebuild b/games-fps/doomsday/doomsday-2.3.0.ebuild
new file mode 100644
index 000000000000..47cd24259c18
--- /dev/null
+++ b/games-fps/doomsday/doomsday-2.3.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit cmake python-any-r1 qmake-utils readme.gentoo-r1
+
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="https://www.dengine.net"
+SRC_URI="https://downloads.sourceforge.net/project/deng/Doomsday%20Engine/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="demo fmod freedoom fluidsynth openal tools"
+
+RDEPEND="
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5=[-gles2-only]
+ dev-qt/qtnetwork:5=
+ dev-qt/qtopengl:5=
+ dev-qt/qtwidgets:5=
+ dev-qt/qtx11extras:5=
+ media-libs/assimp
+ net-misc/curl
+ sys-libs/zlib
+ fmod? ( media-libs/fmod:1 )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ openal? ( media-libs/openal )
+ tools? ( sys-libs/ncurses:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+PDEPEND="
+ demo? ( games-fps/doom-data )
+ freedoom? ( games-fps/freedoom )
+"
+
+S="${WORKDIR}/${P}/${PN}"
+
+DOC_CONTENTS="You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD, or Doom64 wads to a folder of your choice and then tell the game engine where that folder is. This is different to older versions, which had separate launchers for each game and required the files to be in a specific place."
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Fix QA warning for "installing to one or more unexpected paths"
+ sed -e "10s:/texc:/${PF}:" -i tools/texc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDENG_ASSIMP_EMBEDDED="OFF"
+ -DDENG_ENABLE_TOOLS="$(usex tools)"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DQMAKE=$(qt5_get_bindir)/qmake
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ mv -v "${ED}"/usr/bin/md2tool{,.${PN}} || die
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if use tools; then
+ einfo "In order to prevent a file collision with games-fps/eduke32[tools],"
+ einfo "the utility md2tool has been renamed to md2tool.doomsday."
+ fi
+}